aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-11 18:47:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-11-11 18:47:49 +0100
commitea7510a32fea25f35b7fa7d34eb190c6a6db10bd (patch)
tree65f1fc3039119159e7e7387c4cb56380c768aae2
parent2b781003a4372b793923de8b0f65815c4d5d75a7 (diff)
downloadguix-ea7510a32fea25f35b7fa7d34eb190c6a6db10bd.tar.gz
guix-ea7510a32fea25f35b7fa7d34eb190c6a6db10bd.zip
gnu: Add r-tester.
* gnu/packages/cran.scm (r-tester): New variable. Change-Id: Id7835b32794b8c34ff7f540f8c7a4cfc1d616ba0
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0593288818..e0e29dfe37 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23387,6 +23387,25 @@ co- and contravariate indices, and parallel computations on sequences of
tensors.")
(license license:gpl2+)))
+(define-public r-tester
+ (package
+ (name "r-tester")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tester" version))
+ (sha256
+ (base32 "02q2l0c38ddzlh2jwbzkcyhh2k5a4gnfm8khl8cqvjkjhldi9j5y"))))
+ (properties `((upstream-name . "tester")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://fbertran.github.io/tester/")
+ (synopsis "Tests and checks characteristics of R objects")
+ (description "This package allows users to test characteristics of common
+R objects.")
+ (license license:gpl3)))
+
(define-public r-rarpack
(package
(name "r-rarpack")