aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:41 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:13 +0200
commitea6595badf976d4cd74b7b0096a2eec9d9843aeb (patch)
treeab253a7dafe71f1274854c51c5e985d58e870ae3
parentee33cb893e8db15a5fe4e49c58c5a75bfb02b086 (diff)
downloadguix-ea6595badf976d4cd74b7b0096a2eec9d9843aeb.tar.gz
guix-ea6595badf976d4cd74b7b0096a2eec9d9843aeb.zip
gnu: git: Drop docbook workarounds.
* gnu/packages/version-control.scm (git)[arguments]<#:phases>: Drop docbook-xsl related substitution. [native-inputs]: Add docbook-xml-4.5. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 54e9dcb448..9b4b845abe 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -555,20 +555,6 @@ everything from small to very large projects with speed and efficiency.")
(add-after 'build 'build-subtree
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(with-directory-excursion "contrib/subtree"
- (substitute* "Makefile"
- ;; Apparently `xmlto' does not bother to looks up the
- ;; stylesheets specified in the XML, unlike the above
- ;; substitution. Instead it uses a hard-coded URL. Work
- ;; around it here, but if this is common perhaps we should
- ;; hardcode this path in xmlto itself.
- (("\\$\\(XMLTO\\) -m \\$\\(MANPAGE_XSL\\)")
- (string-append "$(XMLTO) -x "
- (search-input-directory
- (or native-inputs inputs)
- (string-append
- "xml/xsl/docbook-xsl-"
- #$(package-version docbook-xsl)))
- "/manpages/docbook.xsl -m $(MANPAGE_XSL)")))
(invoke "make")
(invoke "make" "install")
(invoke "make" "install-doc")
@@ -721,6 +707,7 @@ everything from small to very large projects with speed and efficiency.")
;; For subtree documentation.
(append asciidoc
docbook2x
+ docbook-xml-4.5
docbook-xsl
libxslt
pkg-config