aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 20:57:19 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:29 +0800
commite9b97b193a9b444399b3cdb33e10906087664b39 (patch)
treebcbb1371e151605dc25928405e77e353e168bbfe
parenta0807675f78bba4889be563dd2823a81c8051a40 (diff)
downloadguix-e9b97b193a9b444399b3cdb33e10906087664b39.tar.gz
guix-e9b97b193a9b444399b3cdb33e10906087664b39.zip
gnu: freeimage: Adjust for libraw 0.21.
* gnu/packages/patches/freeimage-libraw-0.21-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/image.scm (freeimage)[source](patches): Add it. Change-Id: Ief930d50be3e1f44074cd772756fb813bbad4389
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image.scm3
-rw-r--r--gnu/packages/patches/freeimage-libraw-0.21-compat.patch15
3 files changed, 18 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 695c8de3d2..8557924f2f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1248,6 +1248,7 @@ dist_patch_DATA = \
%D%/packages/patches/freecad-vtk-9.3.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-libtiff-compat.patch \
+ %D%/packages/patches/freeimage-libraw-0.21-compat.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/freeimage-CVE-2020-21428.patch \
%D%/packages/patches/freeimage-CVE-2020-22524.patch \
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7d5fc3707e..a709822e5b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1268,7 +1268,8 @@ supplies a generic doubly-linked list and some string functions.")
(search-patches "freeimage-unbundle.patch"
"freeimage-libtiff-compat.patch"
"freeimage-CVE-2020-21428.patch"
- "freeimage-CVE-2020-22524.patch")
+ "freeimage-CVE-2020-22524.patch"
+ "freeimage-libraw-0.21-compat.patch")
;; Take one patch from Arch Linux that adds LibRaw 0.20 compatibility.
(list (origin
(method url-fetch)
diff --git a/gnu/packages/patches/freeimage-libraw-0.21-compat.patch b/gnu/packages/patches/freeimage-libraw-0.21-compat.patch
new file mode 100644
index 0000000000..b7eb7a4035
--- /dev/null
+++ b/gnu/packages/patches/freeimage-libraw-0.21-compat.patch
@@ -0,0 +1,15 @@
+from https://gitlab.archlinux.org/archlinux/packaging/packages/freeimage/-/blob/69548d01896b32f30937a71220a9133055d84705/freeimage-libraw-0.21.patch
+
+diff -ru FreeImage.orig/Source/FreeImage/PluginRAW.cpp FreeImage/Source/FreeImage/PluginRAW.cpp
+--- FreeImage.orig/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:57:11.447801357 +0100
++++ FreeImage/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:58:05.103433138 +0100
+@@ -687,7 +687,7 @@
+ // --------------------------------------------
+
+ // (-s [0..N-1]) Select one raw image from input file
+- RawProcessor->imgdata.params.shot_select = 0;
++ RawProcessor->imgdata.rawparams.shot_select = 0;
+ // (-w) Use camera white balance, if possible (otherwise, fallback to auto_wb)
+ RawProcessor->imgdata.params.use_camera_wb = 1;
+ // (-M) Use any color matrix from the camera metadata. This option only affects Olympus, Leaf, and Phase One cameras.
+