aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org> ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (test-workers) #:use-module (guix workers) #:use-module (ice-9 threads) #:use-module (srfi srfi-64)) (test-begin "workers") (test-equal "enqueue" 4242 (let* ((pool (make-pool)) (result 0) (1+! (let ((lock (make-mutex))) (lambda () (with-mutex lock (set! result (+ result 1))))))) (let loop ((i 4242)) (unless (zero? i) (pool-enqueue! pool 1+!) (loop (- i 1)))) (let poll () (unless (pool-idle? pool) (pk 'busy result) (sleep 1) (poll))) result)) ;; Same as above, but throw exceptions within the workers and make sure they ;; remain alive. (test-equal "exceptions" 4242 (let* ((pool (make-pool 10)) (result 0) (1+! (let ((lock (make-mutex))) (lambda () (with-mutex lock (set! result (+ result 1))))))) (let loop ((i 10)) (unless (zero? i) (pool-enqueue! pool (lambda () (throw 'whatever))) (loop (- i 1)))) (let loop ((i 4242)) (unless (zero? i) (pool-enqueue! pool 1+!) (loop (- i 1)))) (let poll () (unless (pool-idle? pool) (pk 'busy result) (sleep 1) (poll))) result)) (test-end)
uix/snapshot/guix-e8d8b485d0064fec8a8aa51b3ddb612fd722389e.zip'>guix-e8d8b485d0064fec8a8aa51b3ddb612fd722389e.zip
gnu: minetest: Don't use unstable tarball.
* gnu/packages/games.scm (minetest)[source]: Download from git repository.
Diffstat
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0174d5bfa2..c96ccede1e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1612,14 +1612,14 @@ match, cannon keep, and grave-itation pit.")
(name "minetest")
(version "0.4.17.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/minetest/minetest/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest/minetest")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ngb3h6hw0zbsr6isjpyp4fach0g4nbn6bxxv9g354plac6d89fd"))))
+ "19sfblgh9mchkgw32n7gdvm7a8a9jxsl9cdlgmxn9bk9m939a2sg"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags