aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2024-09-06 17:37:09 -0700
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 20:57:30 +0800
commite85ab7d2e52543fc086dce9144748e6f4b908ca9 (patch)
treed0aec11bf25ffb794c8012c3f29c377ab9bceeeb
parent6ba136586db0ea985a7ced261d33515c6cc8c8b4 (diff)
downloadguix-e85ab7d2e52543fc086dce9144748e6f4b908ca9.tar.gz
guix-e85ab7d2e52543fc086dce9144748e6f4b908ca9.zip
gnu: reprotest: Update to 0.7.28.
* gnu/packages/diffoscope.scm (reprotest): Update to 0.7.28. [arguments]<#:phases>: Remove adjust-locales phase. Change-Id: I11a0fd6fa9dae47bb5748dd404856d07a3b08b0c
-rw-r--r--gnu/packages/diffoscope.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 35007a7b80..7d7f39fba7 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -253,7 +253,7 @@ install.")
(define-public reprotest
(package
(name "reprotest")
- (version "0.7.27")
+ (version "0.7.28")
(source
(origin
(method git-fetch)
@@ -262,7 +262,7 @@ install.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0z5i53dy4ax4gbidcqmwqq0686n1g397c79bsscfs94s2y35fsns"))))
+ (base32 "06jm82w05qsx3wskch3fm5mpkpj5jmq7r4yram4ixprxc5j8flg8"))))
(inputs
(list python-debian python-distro python-libarchive-c python-rstr))
(native-inputs
@@ -281,15 +281,6 @@ install.")
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Neither glibc-locales nor glibc-utf8-locales have the C.UTF-8
- ;; locale or several other locales used in reprotest.
- (add-after 'unpack 'adjust-locales
- (lambda _
- (substitute* "reprotest/build.py"
- (("'C.UTF-8'") "'en_US.UTF-8'"))
- (substitute* "reprotest/lib/adt_testbed.py"
- (("export LANG=C.UTF-8") "export LANG=en_US.UTF-8"))
- #t))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((mandir1 (string-append