aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 23:50:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:25 +0200
commite7f082503079847e8a0bc28bb4c9726172ef6483 (patch)
tree525260e60968db970c48ecb24697d7e243807b8a
parent6f48c2b28a73d4e255ab652685d6dff6992ba8ad (diff)
downloadguix-e7f082503079847e8a0bc28bb4c9726172ef6483.tar.gz
guix-e7f082503079847e8a0bc28bb4c9726172ef6483.zip
gnu: Add texlive-a2ping.
* gnu/packages/tex.scm (texlive-a2ping): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6b1c45a699..edb64d413c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1037,6 +1037,32 @@ ones.")
(define-deprecated/alias texlive-union texlive-updmap.cfg)
(export texlive-union)
+(define-public texlive-a2ping
+ (package
+ (name "texlive-a2ping")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/a2ping.1"
+ "doc/man/man1/a2ping.man1.pdf"
+ "doc/support/a2ping/" "scripts/a2ping/")
+ (base32
+ "1lhmh1rnykmi6i5mklj7fwhndw1xxmwy2xsy8j1px8ishf5czhvq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "a2ping.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/a2ping")
+ (synopsis "Advanced PS, PDF, EPS converter")
+ (description
+ "@command{a2ping} is a Perl script command line utility written for Unix
+that converts many raster image and vector graphics formats to EPS or PDF and
+other page description formats. Accepted input file formats are:
+PS (PostScript), EPS, PDF, PNG, JPEG, TIFF, PNM, BMP, GIF, LBM, XPM, PCX,
+TGA. Accepted output formats are: EPS, PCL5, PDF, PDF1, PBM, PGM, PPM, PS,
+markedEPS, markedPS, PNG, XWD, BMP, TIFF, JPEG, GIF, XPM.")
+ (license license:gpl3+)))
+
(define-public texlive-accfonts
(package
(name "texlive-accfonts")