aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-07 15:50:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:17 +0100
commite7d875d56d3ec834f244b69749ac6f7c0d51ed88 (patch)
treee352e09168d44596999d056ec0359135fc775303
parent1222fabbd1b777277f3a10a7fd445e3516fa01c1 (diff)
downloadguix-e7d875d56d3ec834f244b69749ac6f7c0d51ed88.tar.gz
guix-e7d875d56d3ec834f244b69749ac6f7c0d51ed88.zip
gnu: Add go-github-com-decred-dcrd-crypto-blake256.
* gnu/packages/golang-crypto.scm (go-github-com-decred-dcrd-crypto-blake256): New variable. Change-Id: I497f3ef1015d3260f11711cebd1c64eda5df3ac5
-rw-r--r--gnu/packages/golang-crypto.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 963b9ea95c..d098fcf84d 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -550,6 +550,50 @@ one-time authenticator as specified in
@end itemize")
(license license:expat)))
+(define-public go-github-com-decred-dcrd-crypto-blake256
+ (package
+ (name "go-github-com-decred-dcrd-crypto-blake256")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/decred/dcrd")
+ (commit (go-version->git-ref
+ ;; XXX: While waiting on consensus:
+ ;; - https://issues.guix.gnu.org/52362
+ ;; - https://issues.guix.gnu.org/63001
+ ;; - https://issues.guix.gnu.org/63647
+ ;; - https://issues.guix.gnu.org/69827
+ (string-append "crypto/blake256/v" version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mjzlyz2a3516g46kv421nacjd7p4g9l8ih4i7xijvsi480s5pja"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Submodules with their own go.mod files and packed as separated
+ ;; packages.
+ (for-each
+ delete-file-recursively
+ (list "addrmgr" "bech32" "blockchain/standalone" "certgen"
+ "chaincfg/chainhash" "chaincfg" "connmgr" "container/lru"
+ "crypto/blake256/internal/_asm" "crypto/rand"
+ "crypto/ripemd160" "database" "dcrec/edwards" "dcrec" "dcrjson"
+ "dcrutil" "gcs" "hdkeychain" "math/uint256" "mixing" "peer"
+ "rpc/jsonrpc/types" "rpcclient" "txscript" "wire"))))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/decred/dcrd/crypto/blake256"
+ #:unpack-path "github.com/decred/dcrd"))
+ (home-page "https://github.com/decred/dcrd")
+ (synopsis "BLAKE-256/BLAKE-224 crypto hash functions implementation")
+ (description
+ "Package blake256 implements BLAKE-256 and BLAKE-224 with SSE2, SSE4.1,
+and AVX acceleration and zero allocations.")
+ (license license:isc)))
+
(define-public go-github-com-dvsekhvalnov-jose2go
(package
(name "go-github-com-dvsekhvalnov-jose2go")