aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-28 19:50:05 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:40 +0000
commite7c8ca0c59127fffab5725f4237f1d2d6973f9ad (patch)
tree2e6b141a088a52bb7e1318f09e7440093fef4da7
parentf579551b9b2a286e1a2315b186805e259f7242ea (diff)
downloadguix-e7c8ca0c59127fffab5725f4237f1d2d6973f9ad.tar.gz
guix-e7c8ca0c59127fffab5725f4237f1d2d6973f9ad.zip
gnu: python-mock: Enable tests.
* gnu/packages/check.scm (python-mock): Enable tests. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I51db06c53d1baa578da421a30049d440134127d7
-rw-r--r--gnu/packages/check.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index bb0560dc1b..ae259385be 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1435,14 +1435,14 @@ doctest.")
(method url-fetch)
(uri (pypi-uri "mock" version))
(sha256
- (base32
- "0zbnp1kmf7ykc9bvlxamsp15rxsd0ar99v99lbh1hiysrkasm5jy"))))
+ (base32 "0zbnp1kmf7ykc9bvlxamsp15rxsd0ar99v99lbh1hiysrkasm5jy"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-six))
- (build-system python-build-system)
- (arguments
- ;; FIXME: Tests require "pytest", which depends on this package.
- '(#:tests? #f))
(home-page "https://github.com/testing-cabal/mock")
(synopsis "Python mocking and patching library for testing")
(description