aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Wong <wongandj@icloud.com>2025-01-05 18:01:08 -0500
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:23:03 +0200
commite7c83db80307eb214cc2ed3baed790f65f276052 (patch)
tree9c476c48563576fe41df0b388ce017c544fc0cc0
parent6f00eeabe425df555fbf9022f02102055492db7f (diff)
downloadguix-e7c83db80307eb214cc2ed3baed790f65f276052.tar.gz
guix-e7c83db80307eb214cc2ed3baed790f65f276052.zip
gnu: Add rust-fast-image-resize-5.
* gnu/packages/crates-graphics.scm (rust-fast-image-resize-5): New variable. (rust-fast-image-resize-2): Inherit from rust-fast-image-resize-5. Change-Id: Ie0f755bc77ec019a0a8a8c75e1140337343acba0 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-graphics.scm49
1 files changed, 41 insertions, 8 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index afa40236c0..996c174740 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1411,8 +1411,48 @@ EUI-64, also known as MAC-48 media access control addresses.")
(description "Read and write OpenEXR files without any unsafe code")
(license license:bsd-3)))
+(define-public rust-fast-image-resize-5
+ (package
+ (name "rust-fast-image-resize")
+ (version "5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fast_image_resize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qp95mkllxmkc3q0iwh1rj9cgv0rixpjz5wdw6avv2n17g090y7c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; use of undeclared crate or module `testing`
+ #:cargo-inputs (("rust-bytemuck" ,rust-bytemuck-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-document-features" ,rust-document-features-0.2)
+ ("rust-image" ,rust-image-0.25)
+ ("rust-num-traits" ,rust-num-traits-0.2)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-thiserror" ,rust-thiserror-1))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5)
+ ("rust-itertools" ,rust-itertools-0.13)
+ ("rust-libvips" ,rust-libvips-1)
+ ("rust-nix" ,rust-nix-0.29)
+ ("rust-png" ,rust-png-0.17)
+ ("rust-resize" ,rust-resize-0.8)
+ ("rust-rgb" ,rust-rgb-0.8)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tera" ,rust-tera-1)
+ ("rust-walkdir" ,rust-walkdir-2))))
+ (home-page "https://github.com/cykooz/fast_image_resize")
+ (synopsis "Library for fast image resizing with use of SIMD instructions")
+ (description
+ "This package provides a library for fast image resizing with use of
+SIMD instructions.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-fast-image-resize-2
(package
+ (inherit rust-fast-image-resize-5)
(name "rust-fast-image-resize")
(version "2.7.3")
(source
@@ -1422,7 +1462,6 @@ EUI-64, also known as MAC-48 media access control addresses.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0nnm59h7dl2bpi5k2wcd7zz14nl00sa33jiipbjbn48f0i09ly6c"))))
- (build-system cargo-build-system)
(arguments
`(#:tests? #f ; Unresolved import `testing'
#:cargo-inputs
@@ -1438,13 +1477,7 @@ EUI-64, also known as MAC-48 media access control addresses.")
("rust-rgb" ,rust-rgb-0.8)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-walkdir" ,rust-walkdir-2))))
- (home-page "https://github.com/cykooz/fast_image_resize")
- (synopsis
- "Fast image resizing with using of SIMD instructions")
- (description
- "This package provides fast image resizing with using of SIMD instructions.")
- (license (list license:expat license:asl2.0))))
+ ("rust-walkdir" ,rust-walkdir-2))))))
(define-public rust-fast-srgb8-1
(package