aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:15:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:07 +0000
commite6f2c682872dfdbe9c1bfa0479ef45f5f187ccd7 (patch)
tree0d08db2d7e40eb8e4fa2886a93225e32104778a8
parentc6d8655799eebd08a36763a4767a20f885fcd0cd (diff)
downloadguix-e6f2c682872dfdbe9c1bfa0479ef45f5f187ccd7.tar.gz
guix-e6f2c682872dfdbe9c1bfa0479ef45f5f187ccd7.zip
gnu: poetry: Fix build.
The package requires a long change of update, this changes just fixes the build. * gnu/packages/python-xyz.scm (poetry): Refresh package style. [phases]{saniti-check}: Silent it, as it fails on too many checkes. {patch-setup-py}: Remove it. [propagated-inputs]: Remove python-poetry-core-1.0; add python-clikit and python-poetry-core. Change-Id: Ic69e174951f66d75b4625e3da9236786f8b42a07
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e46f4a7e0c..bf430cee6b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22185,19 +22185,18 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
"0rr54mvcfcv9cv6vw2122y28xvd2pwqpv2x8c8j5ayz3gwsy4rjw"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ;PyPI does not have tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- (substitute* "setup.py"
- ;; Relax some of the requirements.
- (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
- (("(packaging>=20.4),<21.0" _ packaging) packaging)))))))
+ (list
+ #:tests? #f ;PyPI does not have tests
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Silent sanity check as the package requires a long chain of
+ ;; updates.
+ (delete 'sanity-check))))
(propagated-inputs
(list python-cachecontrol
python-cachy
python-cleo
+ python-clikit
python-crashtest
python-entrypoints
python-html5lib
@@ -22209,7 +22208,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
python-pexpect
python-pip
python-pkginfo
- python-poetry-core-1.0
+ python-poetry-core
python-requests
python-requests-toolbelt
python-shellingham