aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 20:51:14 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:16 -0500
commite6eeff18561b24fa93601f11874b002bda7c1b7e (patch)
tree8627b3c01c2c827a10274b60c86269b0f7ecc324
parente7908a24d3d570347d7281f88613bd180ec8cc2c (diff)
downloadguix-e6eeff18561b24fa93601f11874b002bda7c1b7e.tar.gz
guix-e6eeff18561b24fa93601f11874b002bda7c1b7e.zip
gnu: xf86-video-mga: Update to 1.6.3.
* gnu/packages/patches/xf86-video-mga-glibc-2.20.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-mga): Update to 1.6.3. Add patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-mga-glibc-2.20.patch17
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 22 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 1cf72dd074..89f56cc54e 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -466,6 +466,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-intel-compat-api.patch \
gnu/packages/patches/xf86-video-intel-glibc-2.20.patch \
gnu/packages/patches/xf86-video-mach64-glibc-2.20.patch \
+ gnu/packages/patches/xf86-video-mga-glibc-2.20.patch \
gnu/packages/patches/xf86-video-openchrome-includes.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch
diff --git a/gnu/packages/patches/xf86-video-mga-glibc-2.20.patch b/gnu/packages/patches/xf86-video-mga-glibc-2.20.patch
new file mode 100644
index 0000000000..3b8277df80
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-mga-glibc-2.20.patch
@@ -0,0 +1,17 @@
+Fix test compilation with exa.h in configure when using glibc 2.20.
+Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
+See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
+
+--- xf86-video-mga-1.6.3/configure.~1~ 2013-12-04 21:10:25.000000000 -0500
++++ xf86-video-mga-1.6.3/configure 2014-12-19 01:06:23.005774736 -0500
+@@ -18464,7 +18464,9 @@
+
+ SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
+- ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
++#include <xorg-server.h>
++"
+ if test "x$ac_cv_header_exa_h" = xyes; then :
+ have_exa_h="yes"
+ else
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 5b5d11b717..210b58a818 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2641,17 +2641,18 @@ devices, thus making direct access unnecessary.")
(define-public xf86-video-mga
(package
(name "xf86-video-mga")
- (version "1.5.0")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-mga-"
+ "mirror://xorg/individual/driver/xf86-video-mga-"
version
".tar.bz2"))
(sha256
(base32
- "03l3wz5kz0hmxmzqqbkgn7pf9d956jlag04rb701a0fr1mw3v66a"))))
+ "1my7y67sadjjmab1dyxckylrggi7p01yk4wwg9w6k1q96pmb213p"))
+ (patches (list (search-patch "xf86-video-mga-glibc-2.20.patch")))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
("xf86driproto" ,xf86driproto)