aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 11:26:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:41:28 +0100
commite644f9fa4911eaad2ddf0c14dd6fc9751f4d1f53 (patch)
treeca938be0b8d3c2a671ec51ecf58ef0a096556052
parentcf6cbc34f524353ea5fc7833d9a5f7704c953a74 (diff)
downloadguix-e644f9fa4911eaad2ddf0c14dd6fc9751f4d1f53.tar.gz
guix-e644f9fa4911eaad2ddf0c14dd6fc9751f4d1f53.zip
gnu: gnome-settings-daemon: Update to 3.28.1.
* gnu/packages/gnome.scm (gnome-settings-daemon): Update to 3.28.1. [build-system]: Use meson-build-system. [arguments]: Override udev rules directory with configure flags. [native-inputs]: Add glib:bin. [inputs]: Add alsa-lib, colord, and wayland.
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4515208adb..196ff43999 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3165,7 +3165,7 @@ services for numerous locations.")
(define-public gnome-settings-daemon
(package
(name "gnome-settings-daemon")
- (version "3.24.3")
+ (version "3.28.1")
(source
(origin
(method url-fetch)
@@ -3174,20 +3174,27 @@ services for numerous locations.")
name "-" version ".tar.xz"))
(sha256
(base32
- "14w5jhpq02mbcxvn41qcj3cjfqdr3sgzl96c6glwpdrjphw61i38"))))
- (build-system glib-or-gtk-build-system)
+ "0z9dip9p0iav646cmxisii5sbkdr9hmaklc5fzvschpbjkhphksr"))))
+ (build-system meson-build-system)
(arguments
- `(;; Color management test can't reach the colord system service.
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ (list (string-append "-Dudev_dir="
+ (assoc-ref %outputs "out")
+ "/lib/udev/rules.d/"))
+ ;; Color management test can't reach the colord system service.
#:tests? #f))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("glib:bin" ,glib "bin") ; for glib-mkenums
+ ("pkg-config" ,pkg-config)
("intltool" ,intltool)
("xsltproc" ,libxslt)
("libxml2" ,libxml2) ;for XML_CATALOG_FILES
("docbook-xml" ,docbook-xml-4.2)
("docbook-xsl" ,docbook-xsl)))
(inputs
- `(("colord" ,colord)
+ `(("alsa-lib" ,alsa-lib)
+ ("colord" ,colord)
("libgudev" ,libgudev)
("upower" ,upower)
("polkit" ,polkit)
@@ -3207,6 +3214,7 @@ services for numerous locations.")
("libwacom" ,libwacom)
("librsvg" ,librsvg)
("xf86-input-wacom" ,xf86-input-wacom)
+ ("wayland" ,wayland)
("network-manager" ,network-manager)))
(home-page "https://www.gnome.org")
(synopsis "GNOME settings daemon")