aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-21 23:01:43 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commite61d34b8b0f0d17f3b44f1d44ba75a35c88df298 (patch)
tree1d360e5f32d13d021b3163118f2d9a8ba1469e30
parent27eecaac18859f08459e45a857947dd8414a8189 (diff)
downloadguix-e61d34b8b0f0d17f3b44f1d44ba75a35c88df298.tar.gz
guix-e61d34b8b0f0d17f3b44f1d44ba75a35c88df298.zip
gnu: Add go-github-com-youmark-pkcs8.
* gnu/packages/golang-crypto.scm (go-github-com-youmark-pkcs8): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: If16a5d911d645396c5976893f2fc43a7f26bf283
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 43b1356d3f..a9c8b68d4e 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1493,6 +1493,34 @@ package is intended for interoperability with the standard library and the
possible.")
(license license:bsd-3))))
+(define-public go-github-com-youmark-pkcs8
+ (package
+ (name "go-github-com-youmark-pkcs8")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/youmark/pkcs8")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ckdrwa5rmp2c85936qd9d0gzrnrvqfg0297ansz5frdhg6fc6nq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/youmark/pkcs8"))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (home-page "https://github.com/youmark/pkcs8")
+ (synopsis "Functions to parse and convert private keys in PKCS#8 format")
+ (description
+ "@code{pkcs8} implements functions to process private keys in PKCS#8
+format, as defined in RFC 5208 and RFC 5958. It can handle both unencrypted
+PKCS#8 PrivateKeyInfo format and EncryptedPrivateKeyInfo format with
+PKCS#5 (v2.0) algorithms.")
+ (license license:expat)))
+
(define-public go-lukechampine-com-blake3
(package
(name "go-lukechampine-com-blake3")