aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-12-22 17:26:45 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:02 +0100
commite5eea7d9cb33e83597b0d3fc3ecb5dc71c8765e9 (patch)
tree52b740413b40f1c44d10308e80ab8fec0448de29
parent8b80a84d706f9fdaad36696bf96016b482f7f8b3 (diff)
downloadguix-e5eea7d9cb33e83597b0d3fc3ecb5dc71c8765e9.tar.gz
guix-e5eea7d9cb33e83597b0d3fc3ecb5dc71c8765e9.zip
gnu: Add sagemath-data-conway-polynomials.
* gnu/packages/sagemath.scm (sagemath-data-conway-polynomials): New variable. Change-Id: Ia3a087b19a0ade5d927422bd365283d209df0863 Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/sagemath.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 008f54a5e7..734aabf739 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -381,3 +381,24 @@ by using an optimized quadratic sieve algorithm.")
coefficients of which are modular integers.")
(license (list license:gpl2 license:gpl3)) ; dual licensed
(home-page "https://gitlab.com/sagemath/zn_poly")))
+
+(define-public sagemath-data-conway-polynomials
+ (package
+ (name "sagemath-data-conway-polynomials")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "conway_polynomials" version))
+ (sha256
+ (base32 "1wz03a08kwlswx1pcr5d99ppmhpfzs2a5i969rnb2ghsz1j9yqag"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/sagemath/conway-polynomials")
+ (synopsis "Python interface to Frank Lübeck's Conway polynomial database")
+ (description "This package provides a Python interface to Frank Lübeck's
+Conway polynomial database. These are used in several computer algebra
+systems such as GAP and SageMath to provide quick access to those Conway
+polynomials. The aim of this package is to make them available through a
+generic Python interface.")
+ (license license:gpl3+)))