aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-05 23:17:40 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:44:58 +0800
commite563fff3c466616290c08af01e6af157e974da82 (patch)
tree4f33351324adef6f551b5e7efdf2e27aecd90916
parenta4786b43eed526845bdee5c5756d9fa41ab8a0c3 (diff)
downloadguix-e563fff3c466616290c08af01e6af157e974da82.tar.gz
guix-e563fff3c466616290c08af01e6af157e974da82.zip
gnu: Add wayland-protocols-next.
* gnu/packages/freedesktop.scm (wayland-protocols-next): New variable. Change-Id: I583e15e0414422ffa300d310b083a62efbfde22b
-rw-r--r--gnu/packages/freedesktop.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6941450436..7c6b230cac 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1405,6 +1405,19 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wayland-protocols-next
+ (package (inherit wayland-protocols)
+ (name "wayland-protocols-next")
+ (version "1.36")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+ "wayland-protocols/-/releases/" version "/downloads/"
+ "wayland-protocols-" version ".tar.xz"))
+ (sha256
+ (base32
+ "14kyxywpfkgpjpkrybs28q1s2prnz30k1b4zap5a3ybrbvh4vzbi"))))))
+
(define-public wayland-utils
(package
(name "wayland-utils")