aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 12:34:38 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:25 +0800
commite45b14c525b339fa7b5eba4f3546c0f22122c007 (patch)
tree8ce1d2572d25117d85a896b050f4731ffe261564
parent095f6d5b331a2552d86258d99dbf636376f4102f (diff)
downloadguix-e45b14c525b339fa7b5eba4f3546c0f22122c007.tar.gz
guix-e45b14c525b339fa7b5eba4f3546c0f22122c007.zip
gnu: Add kauth-5.
* gnu/packages/kde-frameworks.scm (kauth-5): New variable. Change-Id: Iad8d436d222957c00bc63f10e7adff847b6b06af
-rw-r--r--gnu/packages/kde-frameworks.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 3acdb522fb..a71be8dddc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1787,6 +1787,27 @@ actions that need to be performed as a privileged user to small set of helper
utilities.")
(license license:lgpl2.1+)))
+(define-public kauth-5
+ (package
+ (inherit kauth)
+ (name "kauth")
+ (version "5.116.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1x0zd6lqv855jkihxpzhxs732qiva31kzjah9hf2j6xaq0dfxqdc"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list dbus extra-cmake-modules qttools-5))
+ (inputs
+ (list kcoreaddons-5 polkit-qt qtbase-5))
+ (propagated-inputs '())))
+
(define-public kcompletion
(package
(name "kcompletion")
Courtès 2020-03-05installer: Run commands without hopping through the shell....Ludovic Courtès 2020-02-12installer: Remove the cow-store overlay after system installation....Mathieu Othacehe 2019-12-29installer: Pass '--fallback' to 'guix system init'....Ludovic Courtès