aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-14 23:28:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:18:09 +0000
commite31019c658f6162c34b052f29274682e4f15fba0 (patch)
tree1bd15a4c2f9937b1f767fb91dd6cf7de6e369fa4
parentb5ef2b6ed3173dc11bdf4ef3f25644ac92498982 (diff)
downloadguix-e31019c658f6162c34b052f29274682e4f15fba0.tar.gz
guix-e31019c658f6162c34b052f29274682e4f15fba0.zip
gnu: senpai: Fix indentation.
* gnu/packages/messaging.scm (senpai): Fix indentation. [native-inputs]: Sort. Change-Id: Ieadee9947e2c0e90c74b645770cd3844af15a7e2
-rw-r--r--gnu/packages/messaging.scm63
1 files changed, 32 insertions, 31 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7c2d585341..72f8b439db 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3698,37 +3698,38 @@ a text snippet), using @code{libphonenumber}.")
(base32 "0l43qfjr0ggpv1hkyyfxp3j6acrbbrl8n6qxlh91gyb2jan03683"))))
(build-system go-build-system)
(arguments
- (list #:import-path "git.sr.ht/~taiite/senpai/cmd/senpai"
- #:unpack-path "git.sr.ht/~taiite/senpai"
- #:install-source? #f
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'build 'build-doc
- (lambda* (#:key unpack-path #:allow-other-keys)
- (invoke "make" "doc"
- "-C" (string-append "src/" unpack-path))))
- (add-after 'install 'install-doc
- (lambda* (#:key unpack-path #:allow-other-keys)
- (let ((man1 (string-append #$output "/share/man/man1"))
- (man5 (string-append #$output "/share/man/man5")))
- (mkdir-p man1)
- (mkdir-p man5)
- (install-file
- (string-append "src/" unpack-path "/doc/senpai.1")
- man1)
- (install-file
- (string-append "src/" unpack-path "/doc/senpai.5")
- man5)))))))
- (native-inputs (list go-git-sr-ht-emersion-go-scfg
- go-github-com-delthas-go-libnp
- go-github-com-delthas-go-localeinfo
- go-github-com-delthas-tcell-v2 ; remove in the next release
- go-github-com-mattn-go-runewidth
- go-golang-org-x-net
- go-golang-org-x-time
- go-mvdan-cc-xurls-v2
- which
- scdoc))
+ (list #:import-path "git.sr.ht/~taiite/senpai/cmd/senpai"
+ #:unpack-path "git.sr.ht/~taiite/senpai"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (invoke "make" "doc"
+ "-C" (string-append "src/" unpack-path))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (let ((man1 (string-append #$output "/share/man/man1"))
+ (man5 (string-append #$output "/share/man/man5")))
+ (mkdir-p man1)
+ (mkdir-p man5)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.1")
+ man1)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.5")
+ man5)))))))
+ (native-inputs
+ (list go-git-sr-ht-emersion-go-scfg
+ go-github-com-delthas-go-libnp
+ go-github-com-delthas-go-localeinfo
+ go-github-com-delthas-tcell-v2 ; remove in the next release
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-net
+ go-golang-org-x-time
+ go-mvdan-cc-xurls-v2
+ scdoc
+ which))
(home-page "https://sr.ht/~delthas/senpai")
(synopsis "Modern terminal IRC client")
(description