aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-12 20:26:26 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 14:10:49 +0100
commite2d9756c8032172b47a312d858b5530e1efb66ac (patch)
tree510df07b776b1afda65caa746eb10ea4fd39a9b9
parent88c4c0fd69816d5f90b3b28e197b3c142b265204 (diff)
downloadguix-e2d9756c8032172b47a312d858b5530e1efb66ac.tar.gz
guix-e2d9756c8032172b47a312d858b5530e1efb66ac.zip
gnu: Add go-github-com-mohae-deepcopy.
* gnu/packages/golang-xyz.scm (go-github-com-mohae-deepcopy): New variable. Change-Id: I29dd0f9c61197e2030bd720bf0ec71c86727f976 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index edaf976e12..d5eb97b8dc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4128,6 +4128,31 @@ explicit ownership.")
without the runtime cost of the standard library reflect.Value.")
(license license:asl2.0)))
+(define-public go-github-com-mohae-deepcopy
+ (package
+ (name "go-github-com-mohae-deepcopy")
+ (version "0.0.0-20170308212314-bb9b5e7adda9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mohae/deepcopy")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "173j05wv4yy8jh9ccjw46xfy1knxwvv1ir6b8l6g9pc5j5damm1f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mohae/deepcopy"))
+ (home-page "https://github.com/mohae/deepcopy")
+ (synopsis "Copy of pointers and values for Golang")
+ (description
+ "@code{deepcopy} implements a functionality of deep copies of things. A
+standard @code{copy} will copy the pointers where @code{deepcopy} copies the
+values pointed to. Unexported field values are not copied.")
+ (license license:expat)))
+
(define-public go-github-com-mreiferson-go-options
(package
(name "go-github-com-mreiferson-go-options")