aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:00 +0200
commite2a47c89ad523450bb6094be97d5f378bd93a002 (patch)
tree7f2341c534c61c4c2d583161ce092c9c3612dc52
parent2ba2e80ee6e19f6ab710035445d8e234f100e25d (diff)
downloadguix-e2a47c89ad523450bb6094be97d5f378bd93a002.tar.gz
guix-e2a47c89ad523450bb6094be97d5f378bd93a002.zip
gnu: btrfs-progs: Update to 6.3.2.
* gnu/packages/linux.scm (btrfs-progs): Update to 6.3.2.
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb903723de..4372a3028f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5875,7 +5875,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "6.3")
+ (version "6.3.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -5883,7 +5883,7 @@ and copy/paste text in the console and in xterm.")
version ".tar.xz"))
(sha256
(base32
- "0zbampc47nq3h8as3rda2apns5sj93ywxnrkal74kjvyg3zvv820"))))
+ "093wy9dsvp22nwlsk203l91h3yzkccvzdw58n3sicy41sncn3wm9"))))
(build-system gnu-build-system)
(outputs '("out" "static")) ;static versions of the binaries in "out"
(arguments
ip-port): Use (lzlib) instead of (guix lzlib) and do not check for lzlib availability. * guix/zlib.scm: Remove it. * m4/guix.m4 (GUIX_LIBZ_LIBDIR, GUIX_LIBLZ_FILE_NAME): Remove them. * tests/lzlib.scm: Use (zlib) instead of (guix zlib) and (lzlib) instead of (guix lzlib), and do not check for zlib and lzlib availability. * tests/publish.scm: Ditto. * tests/substitute.scm: Do not check for lzlib availability. * tests/utils.scm: Ditto. * tests/zlib.scm: Remove it. Mathieu Othacehe 2019-06-20utils: canonical-newline-port: Fix handling of carriage return at buffer end....Prior to this change the added test fails for me locally at byte 1024. It might depend on some default buffer sizes. Fixes <https://bugs.gnu.org/35863>. * tests/utils.scm ("canonical-newline-port-1024"): Add test. * guix/utils.scm (canonical-newline-port): Correct comments on CR/LF. Remove CR even when they're at the end of the buffer. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Robert Vollmert 2019-05-27utils: Support compression and decompression with lzip....* guix/utils.scm (lzip-port): New procedure. (decompressed-port, compressed-port, compressed-output-port): Add 'lzip case. * tests/utils.scm <top level>: Call 'test-compression/decompression' for 'lzip as well. Ludovic Courtès 2019-05-27utils: Test 'compressed-port' and 'decompressed-port' for both gzip and xz....* tests/utils.scm (test-compression/decompression): New procedure. <top level>: Call it for both 'xz and 'gzip. Ludovic Courtès