aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 17:37:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:37 +0000
commite28b014014909715236517857e8f8370548432de (patch)
tree80d85f90d55c5b9bbe9868b4fa10546ab4cee9b7
parentc8fff888e2261fce14ff9ea8ddf1ef6d22aa5cc1 (diff)
downloadguix-e28b014014909715236517857e8f8370548432de.tar.gz
guix-e28b014014909715236517857e8f8370548432de.zip
gnu: python-watchgod: Fix build.
The latest version depends on a long list of Rust packages and maturin build system, this change just fixes the build. * gnu/packages/python-xyz.scm (python-watchgod): [arguments]<phases>: Remove 'sanity-check, all tests passed. [native-inputs]: Remove python-pytest-toolbox. Change-Id: I36e84ed09a2321636257c0a5528bf01aea1d2d7e
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abd5e095bf..15b9cf10d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31608,7 +31608,9 @@ but portable.")
(arguments
(list #:test-flags '(list "-o" "asyncio_mode=auto"
;; PytestUnraisableExceptionWarning
- "-k" "not test_watch_log and not test_awatch")))
+ "-k" "not test_watch_log and not test_awatch")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'sanity-check))))
(native-inputs
(list python-anyio
python-coverage
@@ -31618,7 +31620,6 @@ but portable.")
python-pytest-cov
python-pytest-mock
python-pytest-sugar
- python-pytest-toolbox
python-setuptools
python-wheel))
(home-page "https://github.com/samuelcolvin/watchgod")