aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-07 00:45:35 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-11 12:31:05 +0100
commite234779067fcb7d10d187994e6694cdd6125bf2d (patch)
tree3b3f05be4a25fd1825ac619da29e325e0bc9e9a5
parentc2e2b0376b82a503e064fa826d1b153d94bf0b06 (diff)
downloadguix-e234779067fcb7d10d187994e6694cdd6125bf2d.tar.gz
guix-e234779067fcb7d10d187994e6694cdd6125bf2d.zip
gnu: Add perl-pgplot.
* gnu/packages/maths.scm (perl-pgplot): New variable. Change-Id: Iac06caf5f0c1b142153c011e46aa4fda7704d672
-rw-r--r--gnu/packages/maths.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a6dc1e756f..6cdba70e1b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1300,6 +1300,33 @@ in the terminal or with an external viewer.")
@code{cairo} that provides uniform output to multiple devices.")
(license license:gpl2+)))
+(define-public perl-pgplot
+ (package
+ (name "perl-pgplot")
+ (version "2.34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETJ/PGPLOT-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "1j0hjnhi0rkihviab2s6ninwfm71s73zh89pds1mpg9kf3c1w97z"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "PGPLOT_DIR" (string-append (assoc-ref inputs "giza") "/lib")))))))
+ (inputs (list giza libx11))
+ (native-inputs (list perl-devel-checklib perl-extutils-f77 gfortran))
+ (home-page "https://metacpan.org/release/PGPLOT")
+ (synopsis "Scientific plotting library (using giza)")
+ (description "This package provides PGPLOT bindings for Perl. It uses
+giza instead of PGPLOT for the implementation, though.")
+ ;; Since giza is GPL2+, so is this.
+ (license license:gpl2+)))
+
(define-public gnuplot
(package
(name "gnuplot")