aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-13 17:10:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:41:01 +0300
commite190289e6b243880cba289a5b47fc7dae4b21fb9 (patch)
treefd538078366b6ee178b3744b2585752736ab2666
parent928c64f57d9957a8beca9eaa7a2196afb3ea2b08 (diff)
downloadguix-e190289e6b243880cba289a5b47fc7dae4b21fb9.tar.gz
guix-e190289e6b243880cba289a5b47fc7dae4b21fb9.zip
gnu: rust-rustc-serialize-0.3: Update to 0.3.25.
* gnu/packages/crates-io.scm (rust-rustc-serialize-0.3.25): Update to 0.3.25. [arguments]: Don't skip the build. Skip the tests. [cargo-inputs]: Remove field. [cargo-development-inputs]: Add rust-rand-0.3. [home-page]: Update home-page. [description]: Add that it is deprecated. Change-Id: Ibb25e82421f9940386d19e85329ad58ee1a740db
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ec2c36a8fd..5d73cbbe41 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -57743,29 +57743,28 @@ forth, as well as the ability to create custom thread-pools with ThreadPool.")
(define-public rust-rustc-serialize-0.3
(package
(name "rust-rustc-serialize")
- (version "0.3.24")
+ (version "0.3.25")
(source
- (origin
- (method url-fetch)
- (uri (crate-uri "rustc-serialize" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1nkg3vasg7nk80ffkazizgiyv3hb1l9g3d8h17cajbkx538jiwfw"))))
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-serialize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "00c494bsxjqjvc15h9x2nkgwl6bjdp9bmb9v0xs4ckv0h33lp0zy"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-rand" ,rust-rand-0.3))))
- (home-page "https://github.com/rust-lang-deprecated/rustc-serialize")
+ `(#:tests? #f ; could not find `rustc_serialize` in the crate root
+ #:cargo-development-inputs (("rust-rand" ,rust-rand-0.3))))
+ (home-page "https://github.com/rust-lang/rustc-serialize")
(synopsis "Generic serialization/deserialization support")
(description
"This package provides generic serialization/deserialization support
corresponding to the @code{derive(RustcEncodable, RustcDecodable)} mode in the
compiler. Also includes support for hex, base64, and json encoding and
-decoding.")
- (license (list license:asl2.0
- license:expat))))
+decoding.
+
+This crate is deprecated in favor of serde.")
+ (license (list license:asl2.0 license:expat))))
(define-public rust-rustc-std-workspace-alloc-1
(package