aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-11 08:41:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-11-07 12:33:26 -0500
commite18af936ff85442a841886c9434f862fb595a8b2 (patch)
tree3c1a8da9932de7b6dae95e0a6cdec0c92cfeee96
parenta4db19d8e07eeb26931edfde0f0e6bca4e0448d3 (diff)
downloadguix-e18af936ff85442a841886c9434f862fb595a8b2.tar.gz
guix-e18af936ff85442a841886c9434f862fb595a8b2.zip
gnu: mdds: Update to 2.1.1.
* gnu/packages/boost.scm (mdds): Update to 2.1.1. [source]: Fetch from git. [native-inputs]: New field. Change-Id: I4e71d5c360f4b7305cffd7008e2bbbfcaad2f897
-rw-r--r--gnu/packages/boost.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 98dccf7f16..71999709ed 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019, 2020 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -44,6 +44,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages llvm)
@@ -445,15 +446,18 @@ signals and slots system.")
(define-public mdds
(package
(name "mdds")
- (version "2.0.3")
+ (version "2.1.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://kohei.us/files/mdds/src/mdds-"
- version ".tar.xz"))
- (sha256
- (base32
- "1r68kxqppmhfg0dhz54d0hqzs5882cqrv1x6wpg7lak6gyyws0bc"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mdds/mdds")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0866020brc1kmiryh7dmhjamnywlsd56ks649hy87283k0p7d3bb"))))
(build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
(propagated-inputs
(list boost)) ; inclusion of header files
(home-page "https://gitlab.com/mdds/mdds")
): Add it. Ludovic Courtès 2020-05-14pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable....* gnu/packages/aux-files/run-in-namespace.c (struct engine): New type. (exec_default): New function. (engines): New variable. (execution_engine): New function. (main): Use it instead of calling 'exec_in_user_namespace' and 'exec_with_proot' directly. * tests/guix-pack-relocatable.sh: Add test with 'GUIX_EXECUTION_ENGINE'. * doc/guix.texi (Invoking guix pack): Document 'GUIX_EXECUTION_ENGINE'. Ludovic Courtès 2020-04-24pack: 'guix pack -R' wrapper correctly reports exit code....Fixes <https://bugs.gnu.org/40816>. Reported by Jan (janneke) Nieuwenhuizen <janneke@gnu.org>. * gnu/packages/aux-files/run-in-namespace.c (main): In the 'default' case, check 'WIFEXITED (status)' and exit with the corresponding code in that case. Exit with 255 in other cases. * tests/guix-pack-relocatable.sh: Add test. Ludovic Courtès 2019-08-23pack: '-R' honors the requested output....Fixes <https://bugs.gnu.org/36925>. Reported by Jesse Gibbons <jgibbons2357@gmail.com>. * guix/scripts/pack.scm (wrapped-package): Add 'output*' parameter. [build]: Define 'input' and 'target'; use them instead of #$package and #$output, respectively. (wrapped-manifest-entry): New procedure. (map-manifest-entries): Call PROC directly. (guix-pack): Pass WRAPPED-MANIFEST-ENTRY to 'map-manifest-entries'. Ludovic Courtès 2019-05-18pack: '--localstatedir' and '-R' tests gracefully handle missing /gnu/store....Fixes <https://bugs.gnu.org/35776>. Reported by Ting-Wei Lan <lantw44@gmail.com>. * tests/guix-pack-localstatedir.sh: Set 'storedir' before 'NIX_STORE_DIR'. * tests/guix-pack-relocatable.sh: Likewise. Ludovic Courtès 2019-05-09tests: Ensure 'unshare' works before relying on it....Fixes <https://bugs.gnu.org/35642>. Reported by Josh Holland <josh@inv.alid.pw>. * tests/guix-pack-relocatable.sh: Before invoking 'unshare' at the bottom, add "if unshare -r true" condition. * tests/guix-pack.sh: Likewise. Ludovic Courtès 2019-03-15pack: "-RR" produces PRoot-enabled relocatable binaries....* gnu/packages/aux-files/run-in-namespace.c (exec_with_proot): New function. (main): When 'clone' fails, call 'rm_rf'. [PROOT_PROGRAM]: When 'clone' fails, call 'exec_with_proot'. * guix/scripts/pack.scm (wrapped-package): Add #:proot?. [proot]: New procedure. [build]: Compile with -DPROOT_PROGRAM when PROOT? is true. * guix/scripts/pack.scm (%options): Set the 'relocatable?' value to 'proot when "-R" is passed several times. (guix-pack): Pass #:proot? to 'wrapped-package'. * tests/guix-pack-relocatable.sh: Use "-RR" on Intel systems that lack user namespace support. * doc/guix.texi (Invoking guix pack): Document -RR. Ludovic Courtès 2018-11-06pack: Add test for '--relocatable'....* tests/guix-pack-relocatable.sh: New file. * Makefile.am (SH_TESTS): Add it. Ludovic Courtès