aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:18:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:07 +0200
commite0656bba22c428083f9ea3e2bb56461469c74a40 (patch)
treef3e9a0c1789c492150d2905aa696e92efc41a9a4
parent9512d87387e9f0fdda363dd07e2528636373c089 (diff)
downloadguix-e0656bba22c428083f9ea3e2bb56461469c74a40.tar.gz
guix-e0656bba22c428083f9ea3e2bb56461469c74a40.zip
gnu: Add texlive-fontawesome.
* gnu/packages/tex.scm (texlive-fontawesome): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2e2bfd9bd5..badedc18fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12218,6 +12218,30 @@ weights. LaTeX support is provided.")
;; Dania Iwonae, which are under GUST Font Nosource License.
(license (list license:gpl3+ license:gfl1.0))))
+(define-public texlive-fontawesome
+ (package
+ (name "texlive-fontawesome")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/fontawesome/"
+ "fonts/enc/dvips/fontawesome/"
+ "fonts/map/dvips/fontawesome/"
+ "fonts/opentype/public/fontawesome/"
+ "fonts/tfm/public/fontawesome/"
+ "fonts/type1/public/fontawesome/"
+ "tex/latex/fontawesome/")
+ (base32
+ "0m3wl0jc00h8r4w3fa5vkf062hmaadb2rvf3x9lm4pb0c99ia5x9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fontawesome")
+ (synopsis "Font containing web-related icons")
+ (description
+ "The package offers access to the large number of web-related icons
+provided by the FontAwesome font.")
+ (license license:lppl1.3+)))
+
(define-public texlive-fontsize
(package
(name "texlive-fontsize")