aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-02-03 22:39:54 +0800
committerLudovic Courtès <ludo@gnu.org>2022-02-08 13:34:02 +0100
commite0223aa81e084b77dcbea42b81a4322526e180c8 (patch)
tree6fe68187b072042bdb8a9cd549a9ee71b86bbe5e
parentd22fd0bed9072d6e3098adfc5e4bf32f9fdfc564 (diff)
downloadguix-e0223aa81e084b77dcbea42b81a4322526e180c8.tar.gz
guix-e0223aa81e084b77dcbea42b81a4322526e180c8.zip
gnu: nomad: Depends on proper version of g-golf.
* gnu/packages/guile-xyz.scm (nomad)[inputs]: Replace 'g-golf' with 'guile2.2-g-golf'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8bd4391a72..6e1bbb71e9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3467,7 +3467,7 @@ perform geometrical transforms on JPEG images.")
("guile-readline" ,guile2.2-readline)
("guile-gcrypt" ,guile2.2-gcrypt)
("gnutls" ,gnutls)
- ("g-golf" ,g-golf)
+ ("g-golf" ,guile2.2-g-golf)
("shroud" ,shroud)
("emacsy" ,emacsy-minimal)
;; Gtk
els" version))
+ (sha256
+ (base32 "0265xa9nrp6qp1z7v9kmnd3c8jc0dad2vzin657clk3rrsj2qll5"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; Disable tests requiring access to CRDS servers to download ~500MiB
- ;; of data.
+ ;; Disable tests requiring access to CRDS servers to download ~500MiB of
+ ;; data.
#:test-flags #~(list "-k" "not test_crds_selectors_vs_datamodel")
- #:phases #~(modify-phases %standard-phases
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" "/tmp"))))))
- (propagated-inputs (list python-asdf
- python-asdf-astropy
- python-astropy
- python-numpy
- python-psutil))
- (native-inputs (list python-crds
- python-pytest
- python-pytest-doctestplus
- python-scipy
- python-semantic-version
- python-setuptools-scm))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-asdf
+ python-asdf-astropy
+ python-astropy
+ python-numpy
+ python-psutil))
+ (native-inputs
+ (list python-crds
+ python-pytest
+ python-pytest-doctestplus
+ python-scipy
+ python-semantic-version
+ python-setuptools-scm))
(home-page "https://github.com/spacetelescope/stdatamodels")
(synopsis
"Core support for DataModel classes used in calibration pipelines")
(description
- "Provides DataModel, which is the base class for data models implemented in
-the @acronym{JWST, James Webb Space Telescope} and @acronym{Roman, Nancy Grace
-Roman Space Telescope} calibration software.")
+ "Provides @code{DataModel}, which is the base class for data models
+implemented in the @acronym{JWST, James Webb Space Telescope} and
+@acronym{Roman, Nancy Grace Roman Space Telescope} calibration software.")
(license license:bsd-3)))
(define-public python-stpipe