aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-09-01 21:06:57 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 11:56:29 -0500
commite00c621cbbf58a54ca2dd0c7075f154af26bcd54 (patch)
tree1a4065b9113c2628345025405b18728fbf0d0f05
parentedf097aad5ce3c156dc769a149c0c692a7697f94 (diff)
downloadguix-e00c621cbbf58a54ca2dd0c7075f154af26bcd54.tar.gz
guix-e00c621cbbf58a54ca2dd0c7075f154af26bcd54.zip
gnu: mesa: Update to 24.2.2.
Note the clang input for mesa was in inputs for aarch64-linux but more generally in native-inputs for mesa-opencl. Moved to native-inputs for all (mesa does not retain a reference to clang). * gnu/packages/gl.scm (mesa): Update to 24.2.2. [inputs]: Move clang-18 when building for aarch64-linux to ... [native-inputs]: ... here for all architectures. Add python-ply, and python-pyyaml. Use libclc for all architectures. (mesa-opencl)[inputs, native-inputs]: Remove fields. * gnu/packages/python-xyz.scm (python-pyyaml, python-ply): Add a comment about being dependencies of mesa. Change-Id: Ie262e6ea5a31fda0e410277256c203ea3caed96b
-rw-r--r--gnu/packages/gl.scm49
-rw-r--r--gnu/packages/python-xyz.scm2
2 files changed, 21 insertions, 30 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index f056cc07fa..55625ff3c4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
-;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021-2024 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
@@ -299,7 +299,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "24.0.4")
+ (version "24.2.2")
(source
(origin
(method url-fetch)
@@ -309,7 +309,7 @@ also known as DXTn or DXTC) for Mesa.")
"mesa-" version ".tar.xz")))
(sha256
(base32
- "1w25lwdrb0ffrx2fjk9izbvpcgf9ypfc7v32zybwvjwql0qbvzlh"))))
+ "00hxi7wjp368kh5qq2v25nyzjrf0grsx55w55fg4bgpd0hqps1zx"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -322,35 +322,32 @@ also known as DXTn or DXTC) for Mesa.")
libxxf86vm
xorgproto))
(inputs
- (append
- (if (target-aarch64?)
- (list clang-18)
- '())
- (list elfutils ;libelf required for r600 when using llvm
- expat
- (force libva-without-mesa)
- libxml2
- libxrandr
- libxvmc
- llvm-for-mesa
- vulkan-loader
- wayland
- wayland-protocols
- `(,zstd "lib"))))
+ (list elfutils ;libelf required for r600 when using llvm
+ expat
+ (force libva-without-mesa)
+ libxml2
+ libxrandr
+ libxvmc
+ llvm-for-mesa
+ vulkan-loader
+ wayland
+ wayland-protocols
+ `(,zstd "lib")))
(native-inputs
(append
(list bison
+ clang-18
flex
gettext-minimal
glslang
+ libclc
pkg-config
python-libxml2 ;for OpenGL ES 1.1 and 2.0 support
python-mako
+ python-ply
+ python-pyyaml
python-wrapper
(@ (gnu packages base) which))
- (if (target-aarch64?)
- (list libclc)
- '())
(if (%current-target-system)
(list cmake-minimal-cross
pkg-config-for-build
@@ -595,15 +592,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
(arguments
(substitute-keyword-arguments (package-arguments mesa)
((#:configure-flags flags)
- #~(cons "-Dgallium-opencl=standalone" #$flags))))
- (inputs
- (modify-inputs (package-inputs mesa)
- (prepend libclc)))
- (native-inputs
- (if (target-aarch64?)
- (package-native-inputs mesa)
- (modify-inputs (package-native-inputs mesa)
- (prepend clang-18))))))
+ #~(cons "-Dgallium-opencl=standalone" #$flags))))))
(define-public mesa-opencl-icd
(package/inherit mesa-opencl
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a929466d8..7ebe94716a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6213,6 +6213,7 @@ visualisation and class tracker statistics.")
environments and back.")
(license license:bsd-3)))
+;; WARNING: This package is a dependency of mesa.
(define-public python-pyyaml
(package
(name "python-pyyaml")
@@ -21167,6 +21168,7 @@ Protocol) 0-9-1 protocol that tries to stay fairly independent of the underlying
network support library.")
(license license:bsd-3)))
+;; WARNING: This package is a dependency of mesa.
(define-public python-ply
(package
(name "python-ply")
nu.org> Jack Hill 2020-04-30Merge branch 'master' into core-updates... Conflicts: gnu/local.mk gnu/packages/backup.scm gnu/packages/emacs-xyz.scm gnu/packages/guile.scm gnu/packages/lisp.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/web.scm gnu/packages/xorg.scm Marius Bakke 2020-04-28gnu: Add emacs-wide-int....* gnu/packages/emacs.scm (emacs-wide-int): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Diego Nicola Barbato 2020-03-30Merge branch 'master' into core-updates... Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/guile.scm gnu/packages/linux.scm gnu/packages/package-management.scm gnu/packages/pulseaudio.scm gnu/packages/web.scm Marius Bakke 2020-03-29gnu: emacs-next: Add harfbuzz (text shaping engine) to inputs....* gnu/packages/emacs.scm (emacs-next)[inputs]: Add harfbuzz. [arguments]: Enable harfbuzz in #:configure-flags. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Alexey Abramov 2020-03-28Update email address and Savannah handle for Amin Bandali....* .mailmap, gnu/local.mk, gnu/packages/emacs-xyz.scm, gnu/packages/emacs.scm, gnu/packages/fonts.scm, gnu/packages/fpga.scm, gnu/packages/lean.scm, gnu/packages/maths.scm, gnu/packages/pulseaudio.scm: Update my email address. * build-aux/git-authenticate.scm: Update my Savannah handle. Amin Bandali 2020-03-27gnu: emacs: Fix format strings for compatibility with Guile 3....* gnu/packages/emacs.scm (emacs)[arguments]: In the 'patch-program-file-names' and 'install-site-start' phases, specify port in the calls to FORMAT. Marius Bakke 2020-03-27Merge branch 'master' into core-updates... Conflicts: gnu/packages/icu4c.scm gnu/packages/man.scm gnu/packages/python-xyz.scm guix/scripts/environment.scm guix/scripts/pack.scm guix/scripts/package.scm guix/scripts/pull.scm guix/store.scm Marius Bakke 2020-03-22gnu: emacs: Patch references to /bin/sh....When attempting to run ert-runner in the build side environment where /bin/sh doesn't exist as part of the emacs-elpy test suite, Emacs was throwing the error "Searching for program: No such file or directory, /bin/sh". This is because the default shell when SHELL is not set was "/bin/sh", as can be seen in callproc.c: sh = getenv ("SHELL"); Vshell_file_name = build_string (sh ? sh : "/bin/sh"); Thus, patch the occurrences of "/bin/sh" in the source files of Emacs to refer to their correct store location. * gnu/packages/emacs.scm (emacs)[phases]{patch-program-file-names}: Add phase. Maxim Cournoyer 2020-03-22gnu: emacs-minimal: Install the custom site-start file....This makes the EMACS-MINIMAL package more generally useful, by adding support to load autoload definitions. Note that this doesn't negatively impact the performance of the emacs-build-system, because at that time the --quick option is used, which disables loading site-start.el (which is the one calling GUIX-EMACS-AUTOLOAD-PACKAGES). * gnu/packages/emacs.scm (emacs-minimal)[phases]: Do not delete the 'install-site-start phase. [inputs]: Add the emacs/guix-emacs.el auxiliary file. Maxim Cournoyer 2020-03-22gnu: emacs: Re-indent....* gnu/packages/emacs.scm (emacs): Fix indentation. Maxim Cournoyer 2020-03-22gnu: emacs: Byte compile the site-lisp directory, without coupling....This re-instates what the previously reverted commit did, but without adding a dependency on the (guix build emacs-utils) module. * gnu/packages/emacs.scm (emacs)[phases]{install-site-start}: Define a EMACS-BYTE-COMPILE-DIRECTORY procedure, and use it. Maxim Cournoyer 2020-03-22Revert "gnu: emacs: Byte compile the site-lisp directory."...This reverts commit 4714d0fc1a96eb6d421b64b0b585fe8043dcd07b. Rational: Having to rebuild Emacs every time (guix build emacs-utils) changes is not great. Maxim Cournoyer 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-27gnu: emacs: Fix comment....* gnu/packages/emacs.scm (emacs): Fix comment. Maxim Cournoyer 2020-02-27gnu: emacs: Byte compile the site-lisp directory....* gnu/packages/emacs.scm (emacs): Use the (gnu build emacs-utils) module. Byte compile the site-lisp directory as part of the 'install-site-start' phase. (emacs-minimal, emacs-xwidgets, emacs-no-x, emacs-no-x-toolkit): Reset modules to those of the gnu-build-system. Maxim Cournoyer