aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2024-02-24 21:39:02 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:52 +0300
commitdeb2eec341fb87d2b418deb2d2cea82e39fe7472 (patch)
tree6119609ef2c49a94d0589f056ef34864ce4b691b
parent01e34e99aa76d2341a8414fc5b02a7c56a51e770 (diff)
downloadguix-deb2eec341fb87d2b418deb2d2cea82e39fe7472.tar.gz
guix-deb2eec341fb87d2b418deb2d2cea82e39fe7472.zip
gnu: Add rust-scopetime-0.1.
* gnu/packages/crates-io.scm (rust-scopetime-0.1): New variable. Change-Id: I58f75861760efe9f10f0c773e6c555c6ebf5a163 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6952b6f4f0..5e1700a062 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64013,6 +64013,25 @@ with one of the implemented strategies.")
(base32
"09sy9wbqp409pkwmqni40qmwa99ldqpl48pp95m1xw8sc19qy9cl"))))))
+(define-public rust-scopetime-0.1
+ (package
+ (name "rust-scopetime")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "scopetime" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ngkasx6l072cvigx7q5r33i8acjardr4g8jnwdrcym4758f5vb6"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-log" ,rust-log-0.4))))
+ (home-page "https://github.com/extrawurst/gitui")
+ (synopsis "Log scope runtime")
+ (description "This create is for logging runtime of arbitrary scope.")
+ (license license:expat)))
+
(define-public rust-scraper-0.12
(package
(name "rust-scraper")