aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-20 16:50:33 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 17:43:52 +0200
commitde07c0db4a48cdedc28d7f5b2dcd368f1885e8c9 (patch)
tree52902440815400cf22ec364938173caf792e9e38
parent8e913213d9d072ddf75c48b8db8f32b46d5a2a3c (diff)
downloadguix-de07c0db4a48cdedc28d7f5b2dcd368f1885e8c9.tar.gz
guix-de07c0db4a48cdedc28d7f5b2dcd368f1885e8c9.zip
gnu: Add vcftools.
* gnu/packages/bioinformatics.scm (vcftools): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 883eb19f6a..651018e0f5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -970,3 +970,43 @@ chimeric (fusion) transcripts, and is also capable of mapping full-length RNA
sequences.")
;; STAR is licensed under GPLv3 or later; htslib is MIT-licensed.
(license license:gpl3+)))
+
+(define-public vcftools
+ (package
+ (name "vcftools")
+ (version "0.1.12b")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/vcftools/vcftools_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "148al9h7f8g8my2qdnpax51kdd2yjrivlx6frvakf4lz5r8j88wx"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "MANDIR=" (assoc-ref %outputs "out")
+ "/share/man/man1"))
+ #:phases
+ (alist-cons-after
+ 'unpack 'patch-manpage-install
+ (lambda _
+ (substitute* "Makefile"
+ (("cp \\$\\{PREFIX\\}/cpp/vcftools.1") "cp ./cpp/vcftools.1")))
+ (alist-delete 'configure %standard-phases))))
+ (inputs
+ `(("perl" ,perl)
+ ("zlib" ,zlib)))
+ (home-page "http://vcftools.sourceforge.net/")
+ (synopsis "Tools for working with VCF files")
+ (description
+ "VCFtools is a program package designed for working with VCF files, such
+as those generated by the 1000 Genomes Project. The aim of VCFtools is to
+provide easily accessible methods for working with complex genetic variation
+data in the form of VCF files.")
+ ;; The license is declared as LGPLv3 in the README and
+ ;; at http://vcftools.sourceforge.net/license.html
+ (license license:lgpl3)))