aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Sent <richard@freakingpenguin.com>2024-06-19 22:33:00 -0400
committerAndreas Enge <andreas@enge.fr>2024-06-30 10:59:10 +0200
commitddb0401d82be8b1a43b6f47fb5794d08119f8d54 (patch)
treec0fb598ab18a3710ba8f1a822453e581afe42596
parent1731b45c51e1de1839a7b862ab50ba1c876e745f (diff)
downloadguix-ddb0401d82be8b1a43b6f47fb5794d08119f8d54.tar.gz
guix-ddb0401d82be8b1a43b6f47fb5794d08119f8d54.zip
gnu: Add fastfetch.
* gnu/packages/admin.scm (fastfetch): New variable. Change-Id: I2c8489f0773254b0e9e631c55bf016adb7c6e89b Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1060b3c794..4dba607bd6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -66,6 +66,7 @@
;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Richard Sent <richard@freakingpenguin.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4261,6 +4262,37 @@ everyone's screenshots nowadays.")
information tool.")
(license license:expat))))
+(define-public fastfetch
+ (package
+ (name "fastfetch")
+ (version "2.16.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fastfetch-cli/fastfetch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "112dvfx7gvp6n20i1lkd0jbh897jf7bxjxq96bj4099j3x313y3m"))))
+ (build-system cmake-build-system)
+ (inputs (list dbus
+ glib
+ imagemagick
+ libxcb
+ mesa
+ wayland
+ zlib)) ;for imagemagick and an #ifdef
+ (native-inputs (list pkg-config))
+ (arguments (list #:tests? #f)) ; no test target
+ (home-page "https://github.com/fastfetch-cli/fastfetch")
+ (synopsis "Display system information in a stylized manner")
+ (description
+ "Fastfetch is a tool for fetching system information and displaying it in
+a stylized way. Fastfetch displays this information next to a logo of the
+system distribution, akin to many similar tools.")
+ (license license:expat)))
+
(define-public nnn
(package
(name "nnn")