aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-24 09:10:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:23 +0200
commitdd8e4e826cd3f6330faf37e793b975394f461fd6 (patch)
treefb7b33ac36ee9cc6cadc2398b474ee11b4f4497a
parenta227d37ca440be2bb442f7eb5942631f51c90225 (diff)
downloadguix-dd8e4e826cd3f6330faf37e793b975394f461fd6.tar.gz
guix-dd8e4e826cd3f6330faf37e793b975394f461fd6.zip
gnu: Add rust-expectrl-0.7.
* gnu/packages/crates-io.scm (rust-expectrl-0.7): New variable. Change-Id: I3af804bb5795fa065f124466cbaa04b5e4793dc6
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e9602dd821..be67dc06b1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25059,6 +25059,43 @@ by @file{sysexits.h}.")
testing.")
(license (list license:expat license:asl2.0))))
+(define-public rust-expectrl-0.7
+ (package
+ (name "rust-expectrl")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "expectrl" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ykiqkh2r3ky1244r4j0x49hqawdrfdh1mai6fdapz2kb6989rzd"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; These tests don't do well in the build environment
+ "--skip=bash_control_chars"
+ "--skip=python"
+ "--skip=send")
+ #:cargo-inputs
+ (("rust-async-io" ,rust-async-io-1)
+ ("rust-blocking" ,rust-blocking-1)
+ ("rust-conpty" ,rust-conpty-0.5)
+ ("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-futures-timer" ,rust-futures-timer-3)
+ ("rust-nix" ,rust-nix-0.26)
+ ("rust-polling" ,rust-polling-2)
+ ("rust-ptyprocess" ,rust-ptyprocess-0.4)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/zhiburt/expectrl")
+ (synopsis "Tool for automating terminal applications in Unix")
+ (description
+ "This package provides a tool for automating terminal applications in Unix
+like Don libes expect.")
+ (license license:expat)))
+
(define-public rust-extend-0.1
(package
(name "rust-extend")