aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:52:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:52:59 +0100
commitdd1cd47d1559d2a58bbdd94aac5c23ce18d3f2da (patch)
tree8ff8f09441ef01f01d115da7c2b867f869915e10
parent2657da33fd5fb4a4faf8e450436756c2a6c33b81 (diff)
downloadguix-dd1cd47d1559d2a58bbdd94aac5c23ce18d3f2da.tar.gz
guix-dd1cd47d1559d2a58bbdd94aac5c23ce18d3f2da.zip
gnu: Add go-github-com-ucarion-urlpath.
* gnu/packages/golang-web.scm (go-github-com-ucarion-urlpath): New variable. Change-Id: If11c5bfb6c6457037775d7d6ef64c47244fdaef7
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e0a83a03c7..53eb235640 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4325,6 +4325,31 @@ an interface to implement any other minifier.")
sockets.")
(license license:expat))))
+(define-public go-github-com-ucarion-urlpath
+ (package
+ (name "go-github-com-ucarion-urlpath")
+ (version "0.0.0-20200424170820-7ccc79b76bbb")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ucarion/urlpath")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12ns9lqdz566agdp4y0whgksmidi0zp7759akvx0b79mjzyvypax"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ucarion/urlpath"))
+ (home-page "https://github.com/ucarion/urlpath")
+ (synopsis "REST-like URL path patterns matching")
+ (description
+ "Package urlpath matches paths against a template. It's meant for
+applications that take in REST-like URL paths, and need to validate and
+extract data from those paths.")
+ (license license:expat)))
+
(define-public go-github-com-ugorji-go-codec
(package
(name "go-github-com-ugorji-go-codec")