aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-13 11:30:08 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:26 +0200
commitdc26246ef6321a7a71daaa5f906f8e4965ecabec (patch)
tree8b2109d4b6bc4ddf2a3e43d941f4b03180554819
parentef3bac711b9c7abd77b8d5bbcb1afa9db46589ce (diff)
downloadguix-dc26246ef6321a7a71daaa5f906f8e4965ecabec.tar.gz
guix-dc26246ef6321a7a71daaa5f906f8e4965ecabec.zip
gnu: python-pillow: Fix build with zlib 1.3.
* gnu/packages/patches/python-pillow-use-zlib-1.3.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python-xyz.scm (python-pillow): Use it. Change-Id: I97e706c11f616c42fb604cb616a94663f389a376
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pillow-use-zlib-1.3.patch21
-rw-r--r--gnu/packages/python-xyz.scm4
3 files changed, 25 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 71113d610e..2f66d628da 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1876,6 +1876,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-feedparser-missing-import.patch \
%D%/packages/patches/python-louvain-fix-test.patch \
%D%/packages/patches/python-random2-getrandbits-test.patch \
+ %D%/packages/patches/python-pillow-use-zlib-1.3.patch \
%D%/packages/patches/python-pyreadstat-link-libiconv.patch \
%D%/packages/patches/python-pyls-black-41.patch \
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
diff --git a/gnu/packages/patches/python-pillow-use-zlib-1.3.patch b/gnu/packages/patches/python-pillow-use-zlib-1.3.patch
new file mode 100644
index 0000000000..48863ba8da
--- /dev/null
+++ b/gnu/packages/patches/python-pillow-use-zlib-1.3.patch
@@ -0,0 +1,21 @@
+From 9ef7cb39def45b0fe1cdf4828ca20838a1fc39d1 Mon Sep 17 00:00:00 2001
+From: Andrew Murray <radarhere@users.noreply.github.com>
+Date: Fri, 18 Aug 2023 22:22:51 +1000
+Subject: [PATCH] Updated zlib to 1.3
+
+---
+ Tests/test_file_png.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Tests/test_file_png.py b/Tests/test_file_png.py
+index 3ffe93c6d15..f8df88d6777 100644
+--- a/Tests/test_file_png.py
++++ b/Tests/test_file_png.py
+@@ -79,6 +79,6 @@ def get_chunks(self, filename):
+
+ def test_sanity(self, tmp_path):
+ # internal version number
+- assert re.search(r"\d+\.\d+\.\d+(\.\d+)?$", features.version_codec("zlib"))
++ assert re.search(r"\d+(\.\d+){1,3}$", features.version_codec("zlib"))
+
+ test_file = str(tmp_path / "temp.png")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d88db26f00..1c20631cdb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10249,7 +10249,9 @@ Python list with elements of type @code{PIL.Image} (from the
(snippet '(begin
(delete-file-recursively "src/thirdparty")))
(patches
- (search-patches "python-pillow-CVE-2022-45199.patch"))))
+ (search-patches "python-pillow-CVE-2022-45199.patch"
+ ;; Included in 10.1.0.
+ "python-pillow-use-zlib-1.3.patch"))))
(build-system python-build-system)
(native-inputs (list python-pytest))
(inputs (list freetype