aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-13 15:03:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-13 22:17:21 +0200
commitdc172966ba88895096f2c71dcdc3c4083f412dff (patch)
tree6d876956fd2f315a1f1a48efad682c5b83e67b76
parentb6441f7bd0257783fffecfc6b6b3c6f2950204c2 (diff)
downloadguix-dc172966ba88895096f2c71dcdc3c4083f412dff.tar.gz
guix-dc172966ba88895096f2c71dcdc3c4083f412dff.zip
gnu: Add r-quickjsr.
* gnu/packages/cran.scm (r-quickjsr): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b6a01a99b0..21eaa6fbea 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15583,6 +15583,27 @@ estimation problem.")
;; The CRAN page only says GPL-3.
(license license:gpl3+)))
+(define-public r-quickjsr
+ (package
+ (name "r-quickjsr")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "QuickJSR" version))
+ (sha256
+ (base32
+ "1n09jivw1qvsniyap0ki5ablvkwgggh981hcs7k5wx3lp3qxxlnk"))))
+ (properties `((upstream-name . "QuickJSR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-jsonlite r-r6 r-rcpp))
+ (home-page "https://cran.r-project.org/package=QuickJSR")
+ (synopsis "Interface for the QuickJS lightweight JavaScript engine")
+ (description
+ "This package provides an R interface to the @code{QuickJS} portable
+@code{JavaScript} engine. The engine is bundled entirely within the package,
+requiring no external system dependencies beyond a C compiler.")
+ (license license:expat)))
+
(define-public r-abundant
(package
(name "r-abundant")