aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-08-10 18:51:45 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-08-10 18:51:45 +0800
commitda9fabaf21c43789e8cf382205714f103d446c1f (patch)
tree72f0abb0e1a2522cc764d8814f31341c4ecbd6ee
parent55ab9a98c1f360501d92fcf882f6cbea9f4f83a1 (diff)
downloadguix-da9fabaf21c43789e8cf382205714f103d446c1f.tar.gz
guix-da9fabaf21c43789e8cf382205714f103d446c1f.zip
gnu: mate-control-center: Update to 1.28.0.
* gnu/packages/mate.scm (mate-control-center): Update to 1.28.0. [inputs]: Add elogind, libappindicator, libgtop, and udisks. [arguments]: Add a phase to fake 'libelogind' as 'systemd'. Change-Id: I94158a4085b22a01bae113deb2bab0adf7ad63ed
-rw-r--r--gnu/packages/mate.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index bf17c97b3b..a693156d2b 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -913,17 +913,21 @@ icons on the MATE desktop. It works on local and remote file systems.")
(define-public mate-control-center
(package
(name "mate-control-center")
- (version "1.26.1")
+ (version "1.28.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://mate/" (version-major+minor version) "/"
"mate-control-center-" version ".tar.xz"))
(sha256
- (base32 "022nbgdvhfjj9zdy9zaiagigh3f8r0dzfz4gqmpsayk57cm4jpz0"))))
+ (base32 "1g0lg4x3idilaxhwq1s90pajkvv9i012kzrnk0pxqj2jzl2cgwpb"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'use-elogind-as-systemd
+ (lambda _
+ (substitute* "configure"
+ (("systemd") "libelogind"))))
(add-before 'build 'fix-polkit-action
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure the polkit file refers to the right
@@ -950,11 +954,14 @@ icons on the MATE desktop. It works on local and remote file systems.")
("dconf" ,dconf)
("dbus" ,dbus)
("dbus-glib" ,dbus-glib)
+ ("elogind" ,elogind)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)
("gtk+" ,gtk+)
+ ("libappindicator" ,libappindicator)
("libcanberra" ,libcanberra)
+ ("libgtop" ,libgtop)
("libmatekbd" ,libmatekbd)
("libx11" ,libx11)
("libxcursor" ,libxcursor)
@@ -971,7 +978,8 @@ icons on the MATE desktop. It works on local and remote file systems.")
("mate-settings-daemon" ,mate-settings-daemon)
("pango" ,pango)
("polkit" ,polkit)
- ("startup-notification" ,startup-notification)))
+ ("startup-notification" ,startup-notification)
+ ("udisks" ,udisks)))
(propagated-inputs
(list (librsvg-for-system))) ;mate-slab.pc
(home-page "https://mate-desktop.org/")