aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-12-22 11:21:42 -0300
committerVinicius Monego <monego@posteo.net>2024-12-22 14:00:56 -0300
commitda94cd1ea69559a80d291c6a574b0f23e30c64f2 (patch)
treebb43edb658510dce6819d8f465d14a8e6e35cc20
parent25c98faab77f16ff4286f74f9b40e2e72d4acf91 (diff)
downloadguix-da94cd1ea69559a80d291c6a574b0f23e30c64f2.tar.gz
guix-da94cd1ea69559a80d291c6a574b0f23e30c64f2.zip
gnu: python-primecountpy: Fix build.
* gnu/packages/maths.scm (python-primecountpy)[native-inputs]: Add python-wheel. Change-Id: I5d2034b237106291b2453b25a94b0d164b7ece49
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7f53d50f23..f3265423b4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4110,7 +4110,8 @@ bindings to almost all functions of PETSc.")
(native-inputs
(list python-cysignals
python-cython
- python-setuptools))
+ python-setuptools
+ python-wheel))
(inputs
(list pari-gp
primecount
06nls: Update translations.Julien Lepiller 2022-09-04nls: Update translations.Julien Lepiller 2022-08-10nls: Update translations.Julien Lepiller po/guix/bn.po: New file. po/guix/LINGUAS: Add it. 2022-07-09nls: Update translations.Julien Lepiller po/guix/tr.po: New file. po/guix/LINGUAS: Add it. 2022-06-04nls: Update translations.Julien Lepiller po/packages/tr.po: New file. po/packages/LINGUAS: Add it. 2022-05-01nls: Update translations.Julien Lepiller po/guix/ja.po: New file. po/guix/LINGUAS: Add it. 2022-04-02nls: Update translations.Julien Lepiller * po/packages/fi.po: New file. * po/packages/LINGUAS: Add it. 2022-04-02nls: Enforce translation thresholds.Julien Lepiller * po/doc/guix-cookbook.es.po: Remove file. * po/doc/guix-cookbook.fa.po: Remove file. * po/doc/guix-cookbook.fi.po: Remove file. * po/doc/guix-cookbook.pt_BR.po: Remove file. * po/doc/guix-cookbook.ru.po: Remove file. * po/doc/guix-cookbook.uk.po: Remove file. * po/doc/guix-cookbook.zh_Hans.po: Remove file. * po/doc/guix-manual.fa.po: Remove file. * po/doc/guix-manual.fi.po: Remove file. * po/doc/guix-manual.it.po: Remove file. * po/doc/guix-manual.ko.po: Remove file. * po/doc/guix-manual.sk.po: Remove file. * po/doc/local.mk: Remove them. * doc/local.mk: Remove them. 2022-03-01nls: Update translations.Julien Lepiller * po/doc/guix-cookbook.uk.po: New file. * po/doc/local.mk: Add uk cookbook. * doc/local.mk: Add uk cookbook. * po/guix/fa.po: New file. * po/guix/uk.po: New file. * po/guix/LINGUAS: Add fa and uk. 2022-02-04nls: Update translations.Julien Lepiller * po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add it. * doc/local.mk: Add pt_BR cookbook. 2022-01-09nls: Update translations.Julien Lepiller * po/doc/guix-cookbook.fi.po: New file. * po/doc/guix-manual.fi.po: New file. * po/doc/local.mk: Add them. * doc/local.mk: Add them. * po/guix/fi.po: New file. * po/guix/LINGUAS: Add it. 2021-12-04nls: Update translations.Julien Lepiller 2021-11-06nls: Update translations.Julien Lepiller * po/doc/guix-cookbook.es.po: New file. * po/doc/local.mk: Add 'es' cookbook. * doc/local.mk: Add 'es' cookbook. 2021-10-17nls: Update translations.Julien Lepiller 2021-09-02nls: Update translations.Julien Lepiller * po/packages/it.po: New file. * po/packages/LINGUAS: Add `it'. * po/*/*.po: Update translations. 2021-08-04nls: Update translations.Julien Lepiller * po/doc/guix-cookbook.ru.po: New file. * po/doc/guix-cookbook.sk.po: New file. * po/*/*.po: Update translations. * doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk. (info_TEXINFOS): Add Russian and Slovak cookbooks. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po files. 2021-05-11nls: Update translations.Maxim Cournoyer 2021-05-10nls: Update translations.Maxim Cournoyer 2021-05-03nls: Remove the doc-po-update target.Maxim Cournoyer As discussed with Julien Lepiller on IRC, updating the PO files is not useful. This change removes the target and associated rules that allowed updating them. This has the benefit of not having the PO files updated automatically when generating the .pot files, which was causing spurious changes under the po sub-directory. * po/doc/local.mk (make-update-po-files-rule): Remove function and its uses. (doc-po-update): Remove target. 2021-04-30build: Correct a mistake in the guix-manual.pot rule.Maxim Cournoyer This is a follow-up to commit 0d353b06ec. * po/doc/local.mk: Fix function name in comment. (%D%/guix-manual.pot): Refer to *all* the prerequisites via the $^ special variable rather than $<, which only refers to the first one. Reported-by: Julien Lepiller <julien@lepiller.eu> 2021-04-29build: Make doc-po-update and doc-pot-update targets idempotent.Maxim Cournoyer It used to be that the running the doc-po-update and doc-pot-update targets would redo the same work on every run. This change splits the problem in smaller chunks and specifies build dependencies in a way that outputs only get rebuilt when their inputs changed. * po/doc/local.mk (DOC_PO_FILES): Harmonize escapes. (POT_OPTIONS): Re-indent uniformly. (doc-po-update-%, doc-po-update-cookbook-%): Re-implement with... (make-update-po-files-rule): ... this new function. (TMP_POT_FILES): Remove variable. (%D%/%.pot, %D%/guix-manual.pot): New pattern rules. (doc-pot-update, doc-po-update): Adjust prerequisites accordingly. 2021-04-29build: Build the guix.pot-update and contributing.pot-update targets only once.Maxim Cournoyer * po/doc/local.mk (doc-pot-update): Fix an issue where guix.pot-update an contributing.pot-update were built twice. 2021-04-18nls: Fix Chinese cookbook inclusion.Julien Lepiller * po/doc/local.mk: zh_Hans is for the cookbook, not the manual. 2021-04-18nls: Update 'ru' translation.Julien Lepiller 2021-04-18nls: Add Chinese (Traditional) translation.Julien Lepiller * po/doc/guix-cookbook.zh_Hans.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add it. 2021-04-18nls: Add Korean translation.Julien Lepiller * po/doc/guix-cookbook.ko.po: New file. * po/doc/guix-manual.ko.po: New file. * doc/local.mk (info_TEXINFOS): Add them. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * po/guix/ko.po: New file. * po/guix/LINGUAS: Add 'ko'. * po/packages/ko.po: New file. * po/packages/LINGUAS: Add 'ko'. 2021-04-18nls: Add Italian translation.Julien Lepiller * po/doc/guix-manual.it.po: New file. * po/doc/local.mk (DOC_PO_FILES): Add it. * doc/local.mk (info_TEXINFOS): Add it. * po/guix/it.po: New file. * po/guix/LINGUAS: Add 'it'. 2021-04-18nls: Add Persian translation.Julien Lepiller * po/packages/fa.po: New file. * po/packages/LINGUAS: Add 'fa'. * po/doc/guix-cookbook.fa.po: New file. * po/doc/guix-manual.fa.po: New file. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * doc/local.mk (info_TEXINFOS): Add them. 2021-04-18nls: Add Slovak translation.Julien Lepiller * po/packages/sk.po: New file. * po/packages/LINGUAS: Add 'sk'. * po/doc/guix-manual.sk.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_PO_FILES): Add it. 2021-04-18nls: Add Portuguese (Brazil) translation of the manual.Julien Lepiller 2021-04-18nls: Update 'zh_CN' translations.Julien Lepiller 2021-04-18nls: Update 'es' translations.Julien Lepiller 2021-04-18nls: Update 'de' translations.Julien Lepiller 2021-04-18nls: Update 'fr' translations.Julien Lepiller 2021-04-18nls: Add French translation of the cookbook.Julien Lepiller