aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 10:07:57 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:04 +0800
commitd8ac6016d5d6c81788a6abb7941f1e8bbe054fa5 (patch)
tree99a2fe793a1cf586bea7f32fa3cecab9287fbbaa
parent8ce104cec2edb5c6c6e1dd70d2b7d485c4c0233b (diff)
downloadguix-d8ac6016d5d6c81788a6abb7941f1e8bbe054fa5.tar.gz
guix-d8ac6016d5d6c81788a6abb7941f1e8bbe054fa5.zip
gnu: kde-frameworkintegration: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kde-frameworkintegration): Update to 6.3.0. [inputs]: Remove qtbase-5 and qtx11extras; add packagekit-qt6, appstream-qt6, and qtbase. [arguments]: Use Gexps. [synopsis]: Adjust it. Change-Id: Ia3df0049bcd55d56e107826b9af146c93cf68677
-rw-r--r--gnu/packages/kde-frameworks.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 3cf90709e9..ef23a96e70 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3585,7 +3585,7 @@ applications.")
(define-public kde-frameworkintegration
(package
(name "kde-frameworkintegration")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3594,12 +3594,13 @@ applications.")
"frameworkintegration-" version ".tar.xz"))
(sha256
(base32
- "1dqgzhhh8gnvl8jsvh2i6pjn935d61avh63b4z9kpllhvp9a2lnd"))))
+ "0zscmn1hvv0y7j5r22r6cdmqznkv7h0s6v7a4wmpjgrpnd8haw4l"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules pkg-config))
- ;; TODO: Optional packages not yet in Guix: packagekitqt5, AppStreamQt
- (inputs (list kconfig
+ (inputs (list packagekit-qt6
+ appstream-qt6
+ kconfig
kconfigwidgets
kcoreaddons
ki18n
@@ -3609,18 +3610,17 @@ applications.")
knotifications
kpackage
kwidgetsaddons
- qtbase-5
- qtx11extras))
+ qtbase))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "HOME" (getcwd))
- ;; Make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" (getcwd))
+ ;; Make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
(home-page "https://community.kde.org/Frameworks")
- (synopsis "KDE Frameworks 5 workspace and cross-framework integration plugins")
+ (synopsis "KDE Frameworks 6 workspace and cross-framework integration plugins")
(description "Framework Integration is a set of plugins responsible for
better integration of Qt applications when running on a KDE Plasma
workspace.")