aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-09-28 19:13:12 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-28 19:13:12 +0200
commitd74fc6c8e6428c37a5bfad85b08999ff47000208 (patch)
tree8c0c0ce5f9759a789ca3e5f6246d55e0923ddde2
parent56cd9c6735ca1b9bb475291b460d0d2f18352ce1 (diff)
downloadguix-d74fc6c8e6428c37a5bfad85b08999ff47000208.tar.gz
guix-d74fc6c8e6428c37a5bfad85b08999ff47000208.zip
gnu: wfview: Update to 1.64.
* gnu/packages/radio.scm (wfview): Update to 1.64. [inputs]: Add eudev. [arguments]: Update 'fix-paths' phase. Change-Id: I163aae4e40192b3efd0a2550fa8a624daa95b9c0
-rw-r--r--gnu/packages/radio.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 45da28b9ae..f25f755fd9 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2809,7 +2809,7 @@ software-defined radio receivers.")
(define-public wfview
(package
(name "wfview")
- (version "1.62")
+ (version "1.64")
(source
(origin
(method git-fetch)
@@ -2818,7 +2818,7 @@ software-defined radio receivers.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rrj6h5k8plq4m6fd2yxargfhqcwkxv6bdp4rmgh6bs4prl4wvwd"))))
+ (base32 "0gsijp2h72bdq0jiw8lcfdyp6rwjizngg7wjgkbdm4m05y7c5nj1"))))
(build-system qt-build-system)
(arguments
(list
@@ -2829,7 +2829,13 @@ software-defined radio receivers.")
(lambda _
(substitute* "wfview.pro"
(("\\.\\./wfview/")
- "../"))
+ "../")
+ (("!win32:DEFINES \\+= HOST=.* UNAME=.*")
+ "!win32:DEFINES += HOST=\\\\\\\"guix\\\\\\\" UNAME=\\\\\\\"build\\\\\\\"")
+ (("\\$\\(shell git -C .* HEAD\\)")
+ "")
+ (("!win32:LIBS \\+= -L\\./ -lopus")
+ "!win32:LIBS += -L./ -lopus -lqcustomplot"))
(substitute* '("wfmain.cpp")
(("/usr/share")
(string-append #$output "/share")))))
@@ -2840,10 +2846,9 @@ software-defined radio receivers.")
(invoke "qmake"
(string-append "PREFIX=" #$output)
"../wfview.pro"))))))
- ;; XXX: During the build it complains on missing git and hostname commands
- ;; but it successfully finishes the build.
(inputs
(list eigen
+ eudev
hidapi
opus
portaudio