aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:19 +0200
commitd710086536304701764a30a7bdd7868d77483859 (patch)
treebf7ac759a59b5a4db9016a90777cb2ecc0b43dee
parent852cd69a2a20ea0b85fcd6c5822b7d1e5d132c4e (diff)
downloadguix-d710086536304701764a30a7bdd7868d77483859.tar.gz
guix-d710086536304701764a30a7bdd7868d77483859.zip
gnu: Add texlive-spacingtricks.
* gnu/packages/tex.scm (texlive-spacingtricks): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a403e3c151..1d4d52af79 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96137,6 +96137,28 @@ PSTricks, etc.). Unlike @code{soul} underlines, which are built by repeating
small elements, here each chunk of text to be underlined is a single element.")
(license license:expat)))
+(define-public texlive-spacingtricks
+ (package
+ (name "texlive-spacingtricks")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/spacingtricks/"
+ "source/latex/spacingtricks/"
+ "tex/latex/spacingtricks/")
+ (base32
+ "1c9qhraa8nlxlydia4ymqwgc751hldnzyknlkwy30gyfjwyv4s80")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/spacingtricks")
+ (synopsis "Dealing with some spacing issues")
+ (description
+ "This package provides macros for dealing with some spacing issues, e.g.,
+centering a single line, making a variable strut, indenting a block,
+typesetting a compact list, placing two boxes side by side with vertical
+adjustment.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar