aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 14:41:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 14:41:10 +0200
commitd5dab358661d458b69e235ef7d8d5eba5802772a (patch)
tree4b131a15c46f20235c8dd6553a6fb0f4157854c6
parent874f78a89709d1a112693b4fd05504a4b657f090 (diff)
downloadguix-d5dab358661d458b69e235ef7d8d5eba5802772a.tar.gz
guix-d5dab358661d458b69e235ef7d8d5eba5802772a.zip
gnu: Add texlive-mahjong.
* gnu/packages/tex.scm (texlive-mahjong): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5900203531..b3e9825caa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9271,6 +9271,30 @@ classes, @code{fiche} and @code{cours}, useful to create short high school
documents such as tests or lessons. The documentation is in French.")
(license license:gpl3+)))
+(define-public texlive-mahjong
+ (package
+ (name "texlive-mahjong")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mahjong/" "source/latex/mahjong/"
+ "tex/latex/mahjong/")
+ (base32
+ "1nkj6kri9dpk3gkms4raldzkj3dhsf54vggivb6nh169s7a16m7q")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mahjong")
+ (synopsis "Typeset mahjong tiles using MPSZ Notation")
+ (description
+ "The @code{mahjong} package provides a LaTeX interface for typesetting
+mahjong tiles using an extended version of MPSZ algebraic notation. Its
+features include spaces, rotated, blank, and concealed tiles, as well as red
+fives. The size of the mahjong tiles can be controlled using a package option
+and an optional argument of @code{\\mahjong}. It is primarily aimed at
+Riichi (aka Japanese) Mahjong but can be used to typeset any style of
+mahjong.")
+ (license (list license:expat license:cc-by4.0))))
+
(define-public texlive-matapli
(package
(name "texlive-matapli")