aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-30 14:20:08 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-30 18:37:54 +0200
commitd56f8d5e749496362d76bbbf364c8eba2260c6e5 (patch)
tree232f0f13ed0d17e6011d8b430ad409c59c46ae2c
parent57f65bcc9cbe3c4b834cbe0508cd59f9cf9cd67b (diff)
downloadguix-d56f8d5e749496362d76bbbf364c8eba2260c6e5.tar.gz
guix-d56f8d5e749496362d76bbbf364c8eba2260c6e5.zip
gnu: glibc: _PATH_BSHELL refers to our static bash.
* gnu/packages/base.scm (glibc)[arguments]: Change _PATH_BSHELL in paths.h to refer to STATIC-BASH.
-rw-r--r--gnu/packages/base.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 36c9c638be..5eb44eec36 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -553,6 +553,13 @@ store.")
(("/bin/sh")
(string-append bash "/bin/bash")))
+ ;; Same for the shell used by the 'exec' functions for
+ ;; scripts that lack a shebang.
+ (substitute* (find-files "." "^paths\\.h$")
+ (("#define[[:blank:]]+_PATH_BSHELL[[:blank:]].*$")
+ (string-append "#define _PATH_BSHELL \""
+ bash "/bin/bash\"\n")))
+
;; Make sure we don't retain a reference to the
;; bootstrap Perl.
(substitute* "malloc/mtrace.pl"
2020-06-25Revert "ci: Build Guix System images."...Ludovic Courtès 2020-06-24ci: Build Guix System images.Mathieu Othacehe 2020-05-29image: Do not use VM to create disk-images....Mathieu Othacehe 2020-05-05Merge branch 'master' into core-updatesMarius Bakke 2020-05-05image: Add a new API....Mathieu Othacehe 2020-04-08Merge branch 'master' into core-updates...Marius Bakke 2020-04-07ci: Remove "mips64el-linux-gnuabi64" from '%cross-targets'....Ludovic Courtès 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-13maint: Add 'etc/release-manifest.scm'....Ludovic Courtès 2020-03-10Merge branch 'master' into core-updatesMarius Bakke 2020-03-05ci: Adjust 'channel-build-system' for when the source is a file name....Ludovic Courtès 2020-03-05tests: "make check-system" no longer interns source upfront....Ludovic Courtès 2020-03-05ci: Move 'cross-jobs' procedure to the top level....Ludovic Courtès 2020-02-24ci: Don't cross build bootstrap tarballs to MinGW....Ludovic Courtès 2020-01-31ci: Cross-build for riscv64-linux-gnu....Ludovic Courtès 2019-12-01ci: Make sure the Guix checkout is the one providing Cuirass proc....Clément Lassieur