aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:35 +0200
commitd4973c039c24b7471271aa54a3a3f9cef802a57b (patch)
tree77f05a2612ae2c7a27f08e795490bee971df46d8
parent3bea98500ffe20714cde7fc8d4a8ff82d27cb66c (diff)
downloadguix-d4973c039c24b7471271aa54a3a3f9cef802a57b.tar.gz
guix-d4973c039c24b7471271aa54a3a3f9cef802a57b.zip
gnu: Add texlive-refcheck.
* gnu/packages/tex.scm (texlive-refcheck): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f8670511ef..a78a0caa32 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93750,6 +93750,26 @@ elegant and fits in the box of recipes.")
a document.")
(license license:lppl)))
+(define-public texlive-refcheck
+ (package
+ (name "texlive-refcheck")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/refcheck/" "tex/latex/refcheck/")
+ (base32
+ "1zrwz6450p8gapw2sm7716k0h2si0l3c419xph0i0j9mj381kr8y")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/refcheck")
+ (synopsis "Check references (in figures, table, equations, etc)")
+ (description
+ "The package checks references in a document, looking for numbered but
+unlabelled equations, for labels which are not used in the text, for unused
+bibliography references. It can also display label names in text near
+corresponding numbers of equations and/or bibliography references.")
+ (license license:gpl3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar