aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:06 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:56 +0000
commitd401e309483f1150b8e9275b499af0b687e5c7c5 (patch)
tree20134f555f72f8e70340c6c1641b7a8c31b70019
parent473800b8effd43441a15fe77081500fb3abed0a9 (diff)
downloadguix-d401e309483f1150b8e9275b499af0b687e5c7c5.tar.gz
guix-d401e309483f1150b8e9275b499af0b687e5c7c5.zip
gnu: Add python-sphinx-autodoc-typehints-5.
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints-5): New variable. Change-Id: I465979829851681635d1073658f262a96758cfb5 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/sphinx.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index ef47be148d..95015c30df 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1182,6 +1182,13 @@ enabled web server.")
documenting acceptable argument types and return value types of functions.")
(license license:expat)))
+(define-public python-sphinx-autodoc-typehints-5
+ (package/inherit python-sphinx-autodoc-typehints
+ (propagated-inputs
+ (modify-inputs
+ (package-propagated-inputs python-sphinx-autodoc-typehints)
+ (replace "python-sphinx" python-sphinx-5)))))
+
(define-public python-sphinx-pytest
(package
(name "python-sphinx-pytest")