aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 21:56:52 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:12 -0500
commitd3b406969a0916fed8f7dc7c094de9d523ac12c9 (patch)
treec8badba7cee5329de46cfa874ddd9dfe0b0b8c0e
parente106d0a644d4ae5edc6817c6903ba1d43e2681d2 (diff)
downloadguix-d3b406969a0916fed8f7dc7c094de9d523ac12c9.tar.gz
guix-d3b406969a0916fed8f7dc7c094de9d523ac12c9.zip
gnu: libwnck: Update to 3.32.0.
* gnu/packages/gnome.scm (libwnck): Update to 3.32.0. [build-system]: Use meson-build-system. [native-inputs]: Add glib:bin and gobject-introspection.
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index aa88e94bb6..7969d55788 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2246,7 +2246,7 @@ controls using the Bonobo component framework.")
(define-public libwnck
(package
(name "libwnck")
- (version "3.30.0")
+ (version "3.32.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2254,10 +2254,12 @@ controls using the Bonobo component framework.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0f9lvhm3w25046dqq8xyg7nzggxpmdriwrb661nng05a8qk0svdc"))))
- (build-system gnu-build-system)
+ "1jp3p1lnwnwi6fxl2rz3166cmwzwy9vqz896anpwc3wdy9f875cm"))))
+ (build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; for glib-mkenums
+ ("gobject-introspection" ,gobject-introspection) ; for g-ir-scanner
("intltool" ,intltool)))
(propagated-inputs
`(("gtk+" ,gtk+)
t follow the GNU ;; Build System rules. Instead, it has a makefile that has to be ;; patched to set the prefix, etc., and it has no makefile rules to ;; build its documentation. (replace 'configure (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out")) (doc (assoc-ref outputs "doc"))) (substitute* "makefile" (("^PREFIX[[:blank:]]*=.*$") (string-append "PREFIX = " out "\n")) (("^LOUTLIBDIR[[:blank:]]*=.*$") (string-append "LOUTLIBDIR = " out "/lib/lout\n")) (("^LOUTDOCDIR[[:blank:]]*=.*$") (string-append "LOUTDOCDIR = " doc "/share/doc/lout\n")) (("^MANDIR[[:blank:]]*=.*$") (string-append "MANDIR = " out "/man\n"))) (mkdir out) (mkdir (string-append out "/bin")) (mkdir (string-append out "/lib")) (mkdir (string-append out "/man")) (mkdir-p (string-append doc "/share/doc/lout")) #t))) (add-after 'install 'install-man-pages (lambda* (#:key outputs #:allow-other-keys) (invoke "make" "installman") #t)) (add-after 'install 'install-doc (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "doc"))) (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin:" (getenv "PATH"))) (with-directory-excursion "doc" (every (lambda (doc) (format #t "doc: building `~a'...~%" doc) (with-directory-excursion doc (let ((file (string-append out "/share/doc/lout/" doc ".ps"))) (unless (file-exists? "outfile.ps") (invoke "lout" "-r4" "-o" "outfile.ps" "all")) (copy-file "outfile.ps" file) (invoke "ps2pdf" "-dPDFSETTINGS=/prepress" "-sPAPERSIZE=a4" file (string-append out "/share/doc/lout/" doc ".pdf"))))) '("design" "expert" "slides" "user"))) #t)))))) (synopsis "Document layout system") (description "The Lout document formatting system reads a high-level description of a document similar in style to LaTeX and produces a PostScript or plain text output file. Lout offers an unprecedented range of advanced features, including optimal paragraph and page breaking, automatic hyphenation, PostScript EPS file inclusion and generation, equation formatting, tables, diagrams, rotation and scaling, sorted indexes, bibliographic databases, running headers and odd-even pages, automatic cross referencing, multilingual documents including hyphenation (most European languages are supported), formatting of computer programs, and much more, all ready to use. Furthermore, Lout is easily extended with definitions which are very much easier to write than troff of TeX macros because Lout is a high-level, purely functional language, the outcome of an eight-year research project that went back to the beginning.") (license gpl3+) (home-page "https://savannah.nongnu.org/projects/lout/")))