aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-03 17:02:07 +0100
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 17:36:29 +0800
commitd076ae1c7a3ab34c1d7103b70887eedb2e38a0f5 (patch)
treeaffbf54a4b53c02d28eb11a006e448220ad4ac33
parent4915d321ca473dd91ac1dfb9aa71ae315307140e (diff)
downloadguix-d076ae1c7a3ab34c1d7103b70887eedb2e38a0f5.tar.gz
guix-d076ae1c7a3ab34c1d7103b70887eedb2e38a0f5.zip
gnu: indent: Remove uneeded arguments.
* gnu/packages/code.scm (indent) [arguments]: Remove field. [native-inputs]: Remove automake.
-rw-r--r--gnu/packages/code.scm27
1 files changed, 1 insertions, 26 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 3f7a6de478..b1523f5ac7 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -881,33 +881,8 @@ the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
(sha256
(base32 "15c0ayp9rib7hzvrcxm5ijs0mpagw5y8kf5w0jr9fryfqi7n6r4y"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-docdir
- (lambda _
- ;; Although indent uses a modern autoconf in which docdir
- ;; defaults to PREFIX/share/doc, the doc/Makefile.am
- ;; overrides this to be in PREFIX/doc. Fix this.
- (substitute* "doc/Makefile.in"
- (("^docdir = .*$") "docdir = @docdir@\n"))
- #t))
- (add-after 'unpack 'fix-configure
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.sub and config.guess:
- (with-directory-excursion "config"
- (for-each (lambda (file)
- (install-file
- (string-append (assoc-ref
- (or native-inputs inputs) "automake")
- "/share/automake-"
- ,(version-major+minor
- (package-version automake))
- "/" file) "."))
- '("config.sub" "config.guess")))
- #t)))))
(native-inputs
- (list texinfo automake)) ; For up to date 'config.guess' and 'config.sub'.
+ (list texinfo))
(synopsis "Code reformatter")
(description
"Indent is a program that makes source code easier to read by