aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 22:16:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:54 +0000
commitcf3fe8f507765498169750a0832b7d65a3bffe1e (patch)
tree0ad1fe5b0cbf0d273c32ebbdc43ad2259204174b
parente3f959c7e9985d5ad998d7f4770ca277f1ada9c9 (diff)
downloadguix-cf3fe8f507765498169750a0832b7d65a3bffe1e.tar.gz
guix-cf3fe8f507765498169750a0832b7d65a3bffe1e.zip
gnu: go-github-com-operatorfoundation-shapeshifter-transports: Fix build.
* gnu/packages/golang.scm (go-github-com-operatorfoundation-shapeshifter-transports) [propagated-inputs]: Remove go-github-com-operatorfoundation-monolith-go; add go-github-com-operatorfoundation-monolith-go-1.0.4 (go-github-com-operatorfoundation-monolith-go-1.0.4): New variable. Change-Id: I858a0ca47f448985a563f2e0fce8c6a7c6de7ca7
-rw-r--r--gnu/packages/golang.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7ec52a8b9a..31f2dfe46b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1242,7 +1242,7 @@ cluster segmentation algorithm.")
go-github-com-kataras-golog
go-github-com-mufti1-interconv
go-github-com-opentracing-opentracing-go
- go-github-com-operatorfoundation-monolith-go
+ go-github-com-operatorfoundation-monolith-go-1.0.4
go-github-com-operatorfoundation-obfs4
go-github-com-operatorfoundation-shapeshifter-ipc
go-github-com-shadowsocks-go-shadowsocks2
@@ -1672,6 +1672,23 @@ configuration file.")
(description "Monolith-Go is a Go library for working with byte sequences.")
(license license:expat)))
+;; To build bitmask 0.21.11, remove when it's updated.
+(define-public go-github-com-operatorfoundation-monolith-go-1.0.4
+ (package
+ (inherit go-github-com-operatorfoundation-monolith-go)
+ (name "go-github-com-operatorfoundation-monolith-go")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/OperatorFoundation/monolith-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "066bqlgw5h7a3kxswqlv734asb7nw2y6snsn09yqk0ixj23qw22s"))))))
+
(define-public go-github-com-dpotapov-go-spnego
(let ((commit "298b63a544303a239753d04314aada5bdbad7e4a")
(revision "0"))