aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:14 +0200
commitceab1674aec36d112bc66a85333764e903efae10 (patch)
tree20112f80c93a74a1e3d05bc1cf436274f748e3f9
parent0a5c4fb6c6f720cffdc879944e7739fb14760fad (diff)
downloadguix-ceab1674aec36d112bc66a85333764e903efae10.tar.gz
guix-ceab1674aec36d112bc66a85333764e903efae10.zip
gnu: Add texlive-skills.
* gnu/packages/tex.scm (texlive-skills): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8deae0708c..07c94898c4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95891,6 +95891,29 @@ callbacks and values on the fly, and other features of @code{pgfkeys} are
introduced in a new context.")
(license license:lppl1.3+)))
+(define-public texlive-skills
+ (package
+ (name "texlive-skills")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/skills/" "tex/latex/skills/")
+ (base32
+ "0hvh16a6iziand9wlq48lnaw3ha1lj5g396mpfv1m8ci3r9hydm6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/skills")
+ (synopsis "Create proficiency tests")
+ (description
+ "This package attempts to make it easy for even a LaTeX novice to prepare
+proficiency tests, especially in combination with the @code{exam} document
+class. Thus, almost all command names are very similar. After defining
+skills in the preamble or in an external file, they are declared using labels,
+and can optionally be set as global skills. A skills table is generated to
+summarize the evaluated competencies and to allow for writing down the
+resulting proficiency level.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar