aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-02-25 15:45:54 -0800
committerLudovic Courtès <ludo@gnu.org>2024-02-27 11:51:07 +0100
commitce5f75637575c35a98f80647c1a790d190db1a02 (patch)
tree7b0ab15ba9a3fe51aa44dabde2013bcf20a7d7de
parentdcdc0a5592f8be1b07e8ae1a1420d2c1760a5f0e (diff)
downloadguix-ce5f75637575c35a98f80647c1a790d190db1a02.tar.gz
guix-ce5f75637575c35a98f80647c1a790d190db1a02.zip
gnu: pspp: Update to 2.0.0.
* gnu/packages/statistics.scm (pspp): Update to 2.0.0 [arguments](phases): Patch test case to make pass due to locale [native-inputs]: Switch from Python 2 to Python 3 Change-Id: I9feeab72789347033d2df8f23bda9ea27aaa7dd9 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/statistics.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1c4e2dd66b..d17061205f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -115,7 +115,7 @@
(define-public pspp
(package
(name "pspp")
- (version "1.4.1")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
@@ -123,11 +123,16 @@
version ".tar.gz"))
(sha256
(base32
- "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
+ "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
(build-system gnu-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-test-suite
+ (lambda _
+ (substitute* "tests/output/tex.at"
+ (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
+ "AT_CHECK([LC_ALL=en_US.UTF-8 pspp"))))
(add-before 'check 'prepare-tests
;; Prevent irrelevant errors that cause test output mismatches:
;; ‘Fontconfig error: No writable cache directories’
@@ -149,7 +154,7 @@
`(,glib "bin") ;for glib-genmarshal
perl
pkg-config
- python-2 ;for tests
+ python-3 ;for tests
texinfo))
(home-page "https://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis")