aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-11 10:48:53 +0900
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:15:05 +0200
commitcca1d4d92fb490062b3b0616a838946188cfd700 (patch)
treeb0ed0f17455f403808d4632a2fe21d222633c6e3
parent3d0814a1e7b79a987348995cc9c782eff5422283 (diff)
downloadguix-cca1d4d92fb490062b3b0616a838946188cfd700.tar.gz
guix-cca1d4d92fb490062b3b0616a838946188cfd700.zip
gnu: rust-wasmparser-0.216: Update to 0.218.
* gnu/packages/crates-io.scm (rust-wasmparser-0.216): Replace with... (rust-wasmparser-0.218): ... this. Add comment w.r.t. disabling tests. (rust-wasmparser-0.118): Inherit from it, removing now duplicate fields. (rust-object-0.36): Adjust accordingly. Change-Id: I712c36a92d751447560c9c5ca9770c450cfc5030 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d02af96a84..34d0b4904e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52396,7 +52396,7 @@ form and deobfuscated locally.")
("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
("rust-ruzstd" ,rust-ruzstd-0.7)
- ("rust-wasmparser" ,rust-wasmparser-0.216))))
+ ("rust-wasmparser" ,rust-wasmparser-0.218))))
(home-page "https://github.com/gimli-rs/object")
(synopsis "Unified interface for reading and writing object file formats")
(description
@@ -96266,20 +96266,23 @@ attribute that is not in the shared backend crate.")
and native running processes.")
(license (list license:expat license:asl2.0))))
-(define-public rust-wasmparser-0.216
+(define-public rust-wasmparser-0.218
(package
(name "rust-wasmparser")
- (version "0.216.0")
+ (version "0.218.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "wasmparser" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1qr8j1c15r208d9nsjw01x3w71m9i4g756djnhgk37b1lfzfdpmw"))))
+ (base32 "1p65jvj1i6bh180hd656z8yzkn3zx8vs3a6i5lmsgspczk3ld7mh"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ; failed to resolve: use of undeclared crate or module `wat`
+ ;; The test suite fails with error "failed to resolve: use of undeclared
+ ;; crate or module `wat`" (see:
+ ;; https://github.com/bytecodealliance/wasm-tools/issues/1947).
+ `(#:tests? #f
#:cargo-inputs (("rust-ahash" ,rust-ahash-0.8)
("rust-bitflags" ,rust-bitflags-2)
("rust-hashbrown" ,rust-hashbrown-0.14)
@@ -96302,7 +96305,7 @@ and native running processes.")
(define-public rust-wasmparser-0.118
(package
- (inherit rust-wasmparser-0.216)
+ (inherit rust-wasmparser-0.218)
(name "rust-wasmparser")
(version "0.118.2")
(source