aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 21:08:15 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 21:08:15 +0800
commitcc2619a7bd7542d834762de2430937a59d1f3a36 (patch)
treef139c1fbf78ea3daea10ec1b0d0d0c9b1518131b
parent2305b94c2ecb5354c2142b02e28ec861f93a21e4 (diff)
downloadguix-cc2619a7bd7542d834762de2430937a59d1f3a36.tar.gz
guix-cc2619a7bd7542d834762de2430937a59d1f3a36.zip
gnu: trydiffoscope: Update Style.
* gnu/packages/diffoscope.scm (reprotest): Reindent. [arguments]: Use G-expression. Remove trailing #t. Change-Id: I5d77472405adcca35eca7bed9663f30f1f8ed18e
-rw-r--r--gnu/packages/diffoscope.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index a6625112ff..0b2591f31a 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -302,33 +302,33 @@ them in detail for later analysis.")
(license (list license:gpl3+ license:gpl2+))))
(define-public trydiffoscope
- (package
- (name "trydiffoscope")
- (version "67.0.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0k698g4fws63rnav4pvfsf1hfds867xan59mmv5zw71r58lm6cxb"))))
+ (package
+ (name "trydiffoscope")
+ (version "67.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0k698g4fws63rnav4pvfsf1hfds867xan59mmv5zw71r58lm6cxb"))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((share (string-append (assoc-ref outputs "out") "/share/")))
- (mkdir-p (string-append share "/man/man1/" ))
- (invoke "rst2man.py"
- "trydiffoscope.1.rst"
- (string-append share "/man/man1/trydiffoscope.1"))
- (mkdir-p (string-append share "/doc/" ,name "-" ,version))
- (install-file "./README.rst"
- (string-append share "/doc/" ,name "-" ,version)))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((share (string-append #$output "/share/")))
+ (mkdir-p (string-append share "/man/man1/"))
+ (invoke "rst2man.py" "trydiffoscope.1.rst"
+ (string-append share "/man/man1/trydiffoscope.1"))
+ (mkdir-p (string-append
+ share "/doc/" #$name "-" #$version))
+ (install-file
+ "./README.rst"
+ (string-append share "/doc/" #$name "-" #$version))))))))
(propagated-inputs
(list python-requests))
(native-inputs