aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-06 12:16:57 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-19 19:49:00 +0200
commitcbe8158e18d557f37350cb03afc39eb046c1ab3d (patch)
tree9301e0e013b76ee87f8503f78ad0a5a0c8624205
parent2af8c6caffecbaabae813f567858a21854ed5964 (diff)
downloadguix-cbe8158e18d557f37350cb03afc39eb046c1ab3d.tar.gz
guix-cbe8158e18d557f37350cb03afc39eb046c1ab3d.zip
gnu: Add emacs-rbs-mode.
* gnu/packages/emacs-xyz.scm (emacs-rbs-mode): New variable. Change-Id: I20b8b597426b355333375faaf97aa3f776cc369d Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a31e942e00..c5b1568a4a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3384,6 +3384,26 @@ on the eyes during night and day. They only support GUI and 256 colour
terminals.")
(license license:gpl3+))))
+(define-public emacs-rbs-mode
+ (package
+ (name "emacs-rbs-mode")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ybiquitous/rbs-mode")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1ibn8246q0yqdnf3qdww9rvzac9gla7gzjj0n5j5x08brgj5ll2h"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ybiquitous/rbs-mode")
+ (synopsis "Major mode for Ruby type signature")
+ (description
+ "RBS mode is a major mode for Ruby type signature language (RBS). It
+provides basic supports for syntax highlighting and indentation.")
+ (license license:gpl3+)))
+
(define-public emacs-reformatter
(package
(name "emacs-reformatter")